Cadence is always at 255 RPM’s….help…

Hi there. I’m new to TR but love it. I have a wahoo smart trainer and a stage 2 power meter. The problem is my cadence is always reading 255 RPMs which is not correct. Anyone have answers on a fix?

I run TR off my iPad as well.

Happy Holidays!

Ray

Maybe you haven’t connected a cadence sensor. I’d connect the stages as both a power and cadence sensor. Then to keep the trainer resistance linked to that, turn on powermatch on the wahoo. (Some people have issues with powermatch, but I’d see if it works for you first).

I’ve been using a wahoo kickr core in ERG mode for about 6weeks and the same has happened to me twice now - tr app displays 255rpm and seems the only fix is to end workout. Tho it displays 255rpm I found it does not affect erg mode so I can continue my workout as usual and disregard cadence displayed on my android screen. I just assumed it’s a Bluetooth glitch I guess.

1 Like

This sounds like a total glitch / TR getting a corrupted value or no value, given that 255 decimal = 11111111 binary.

2 Likes

If the wahoo is anything like the cadence sensor on my flux you’ll need to run a separate cadence sensor for accuracy.

I doubt you can extract just the cadence from crank power meter if your using this along side your smart trainer

If it’s picking up cadence from the trainer maybe the wheel circumference is wrong? The value might be set to the wheel diameter and not the circumference. As a rough calculation 255/π (255/3.14159) ~= 81rpm which sounds about right.

Wheel circumference will have no impact on the trainer measured cadence.

The trainer cadence is simply looking for “pulses” and “drops” in power and uses that to estimate the cadence. It’s the reason it is actually fallible in some cases, when people have a particularly smooth power delivery and/or a light power level.

2 Likes

Thanks for the answer…unfortunately I think it’s something else. When riding on TR, I also turn on my garmin 1030 bike computer. It picks up the cadence flawlessly….but TR on an ipad does not. I’m still searching for a possible fix.

Thanks!

Maybe you’re correct. I ride with my garmin 1030 bike computer while doing TR and the cadence on the garmin is perfect. On TR (on the ipad) it is registering 255. Any ideas on how to fix are appreciated.

I would ping TR support on this. I think the info they can see could pinpoint if my hunch is correct.

The only suggestions I have to try and fix this on your iPad would be to delete the TR app and all of the related data, and then re-download it. Also see if your devices are registered in your list of Bluetooth devices, if so, I would remove them. I would do all of this in this order:

  • Delete TR app and its data
  • Remove your trainer, heart rate monitor, cadence, etc. from the list of BlueTooth devices on your iPad
  • Power off your iPad. Wait 30 seconds, power it back on - this is being overly cautious
  • Re-download the TR app, and set everything back up

See if this fixes the problem.

Good advice. I’ll reach out to TR support and see what they say. Thanks for your input and expertise.

1 Like

Let us know what you here back from TR support. Truly curious :grinning:

You can very easily set it up so TR gets the cadence from a Stages power meter but use the power from the Kickr. That’s exactly what I do. It is just a checkbox on the Stages sensor in TR that says cadence-only.

I’ll give that a shot……Thanks for the reply.

I think you are right.

Seems to be reporting the maximum value for an unsigned integer (1 byte), which as you say is 255 Decimal (FF hex), it is probably not ‘seeing’ the cadence reading at all.

Are you using bluetooth or ant+? With bluetooth, you cannonly receive the signal with one device, so if its linked to the garmin, the TR app won’t see anything.

Also check which of your two power sources (wahoo and stages) is connected to TR for power and cadence.