🎉 Build & Sync Custom Workouts from Training Peaks & Final Surge 🎉

I am loving this feature. Thanks TR.

@ryanppax sorry for the delay on this, but we pushed a few small fixes to the integration today. Would you mind giving things a shot to confirm things are pulling properly on your end?

Yep, I put a test in for tomorrow and it came in

@bnied See above.

2 Likes

I’ve been using this recently and it’s definitely a great addition.

Apart from ramping warmups / cooldowns correctly, one other suggestion is to get the cadence targets to display as workout text.

Might as well page @bnied too :grin:

This is awesome! I normally just use TR’s plans but for the next 8 weeks got a special TP plan. Now, I can use it with the TR App. Yay!

I can’t seem to push my TP plan starting tomorrow to TR. I’m a premium member and have re-authorized. Do the workouts sync 1 day ahead or day of?

From the first post of this thread:

Maybe try reauthorizing? Make sure the TP workout uses % ftp.

Figured it out…the first workout is HR only.

Doing SS #4?

Correct. Hoping Gateway happens…

No chasing TSS on those, and like you found out those HR workouts won’t sync to TR. Fingers crossed :crossed_fingers:t3: for ya on Gateway

1 Like

@IceBear @giefer @Michael_Tate i tried to request it here, hope you support the thread! :sunglasses:

is there the possibility to only sync planned workouts (Workout of the Day) from Training Peaks to TR?

i don’t wan’t to sync the finished ride from TR back to Training Peaks, because in the Trainerroad File i haven’t L/R information of my Vector 3.

For this i record the Trainerroad Ride with Garmin Edge and i sync then Garmin with L/R information to Training Peaks.

Training Peak workouts are really only working with Target Power only?
or %FTP with Range is allowed too?

I had an issue on Saturday with my custom training peaks workout. I skipped ahead in the workout and when I finished it gave me the the total time for the ride including the 30 min I skipped ahead not the correct time 30 min less. Anyone have this

My TP workouts are % FTP and also % FTP with range and both types synced to TrainerRoad.

1 Like

i tried it yesterday with good luck, first i created the workout only with %FTP “Target” power, then i changed it to “Range”, so the Target Power was the avg value of the target i wanted, the ride himself was correct, but in the the ride analyze himself the target displays wrong.

My Target was 345W, but here it shows me a 318W Target:

Report that to support@trainerroad.com

2 Likes

done!

1 Like