Bluetooth headphones causing ERG dropouts? H3 & group workouts

I’ve only had this happen while doing group workouts, and during group workouts I use BT headphones attached to my Win10 laptop for both music & group workout audio. In the last two group workouts I’ve done, my H3 erg has dropped, either causing me to try to spin somewhat furiously to keep on target power or completely miss a sprint interval. Both times the erg comes back at the start of the next interval step.

Because it has happened during group workouts, I’m wondering if it could be my BT headphones causing interference. After a group workout this morning I did a brief workout alone and it happened again, so it doesn’t seem limited to just group workouts, but I still had the BT headphones connected to my laptop. When I’m riding alone I usually use corded headphones for my phone or Roku remote, and don’t sync any headphones to the device running TR. Curious if anybody else has had this problem?

You connecting via app, computer and ant/bt?? Used to have a H3 prior to selling to my bro and getting a N2T

Everything is BT connected to the PC right now. I was thinking about switching the H3 to ANT (I have a USB stick for the PC) to see if that helped. HRM is BT to the PC as well. Lots going on.

OK i have the EXACT same issue, with everything on PC.
I had made the switch to ANT+ and i still experience BT dropouts and it seems to occur every approx 40-50min of workout. Not sure if you are experiencing anything similiar?
I have updated all drivers on Win10, replaced the BT USB key, have tried different headphones, and tried different trainers…still have the same issues.

1 Like

Dealt with this issue for a while in my basement.

Here’s what I was running:

H3 via ANT+ on dongle to PC (running over wifi) (I run a Garmin HR chestrap, Garmin Cadence, and Powertap P1 pedals running Power Match as my main power source - also on ANT+)
Jaybrid Tarah Pro Bluetooth Headphones to Firestick all running over WiFi.

I was experiencing regular dropouts of the H3 with this setup to the dongle.

Here are the changes I made:

Ethernet cable running to PC now
Ethernet cable running to firestick
H3 is still running ANT+ to dongle along with items listed above
Bluetooth headphones for Firestick

So, essentially, I took away any wifi signal coming into the space and everything that was wifi is now running CAT6 cable.

I have had ZERO dropouts since making this change.

One change that TrainerRoad support asked me to try was running on Bluetooth for one item and ANT+ for another, so the signal doesn’t get crowded on a channel.

Hope that helps a little.

3 Likes

Interesting that you had issue with jaybirds as well. This is what I am using but i have the Vista’s.

2.4ghz is a radio wasteland. BT, wifi, and any other weird proprietary wireless gadgets use it. Heck, microwave ovens operate near the zone, too. The best you can do is move afflicted devices as far away from any such transmitters.

1 Like

Sorry to hear this. It’s not a bad idea to get in touch with support, and include that you’re using BLE headphones and all the aforementioned devices/occurrences. They’ll be able to look at your ride log and any potential troubleshooting steps to help mitigate device dropouts, check for firmware updates, and any other signal strengthening tips! They’ll sort you out! :v:

1 Like

Funny you should mention this, and @614irondad too. In my old setup I had switched off the 2.4g spectrum on my router because I was getting tons of ANT+ dropouts, and it solved the problem instantly. I need to look at the new router (and we moved) to see if the 2.4g is on and make sure I don’t have any devices that are only 2.4g (could be the case with the kids’ cheap chromebooks from school now!).
Going wired in the current setup isn’t an option but could potentially be when the basement remodel gets finished!

Thanks for everybody’s tips and comments.

Yeah, great idea to see if you can switch off the 2.4ghz channels (I seem to recall some older apple products don’t support 5ghz is the main problem here). Especially if issue is more prone to occur in group workouts, as it could be the higher bandwidth needed for all the video transmission is really swamping the spectrum. Anything you can do to move the computer away from your trainer, and an bt/ant+ usb adapter closer to your trainer, the better. I know when I used my laptop with zwift, I got the best results running a long usb cable directly under my neo with the ant+ dongle right there. And that was just vs plugging the ant+ dongle in 3ft away to my side.

1 Like

I ride in the basement with fluorescents overhead , used to gets lots of drop outs. I shut them off and use a pole lamp now and this has fixed most of it

Interference Caused by Fluorescent Lighting Systems using Electronic Ballasts

Modern electronic ballasts typically operate in the 20 KHz to 60 KHz range and may cause interference with communication equipment that did not occur with traditional electromagnetic 60Hz ballasts. Electromagnetic Interference (EMI) can cause static on radio communications or interfere with the operation of any electronic device especially wireless communication devices.

I’ve been relying on BT because it is allegedly better, but I have a USB extension that I can run for the ANT+ dongle. Will try that later this week and look at the router for 2.4g and see if I can make any progress.

The 2.4GHz band is a bit of a wasteland, as mentioned, so number one thing is to not use 2.4GHz for wifi, and use 5GHz instead. If you do need to use 2.4GHz, use either channel 1 or 6, since 11 (really anything between 8 and 12) overlaps with the specific frequency that ANT+ uses:


This was a factor for me when I used to stream (or at least tried to!) stream music through my phone to wired headphones. Changed the channel, and problem (mostly) went away. Using a USB extension cable so that the ANT+ dongle could be physically closer to the power meter also helped.

Bluetooth is a bit different, and uses frequency hopping so there’s less that you can do besides using the same USB extension cable idea as above, so that the signal you want your computer to hear is the closest to the antenna, and strongest.

2 Likes