4iiii trouble shooting

I have a 4iiii left side power meter that has suddenly stopped working. I have changed the battery, turned bluetooth on and back off, and tried 3 different apps with no success. Does anybody have any other suggestions on what i can try next?

When I had similar problems with my 4iiii Precision PM their support team sent these instructions to me:

(it didn’t sort my issue, I ended up having to get a replacement, but worth a try).

This is going to sound dumb but make sure you have the battery facing the correct direction. I had a “broken” 4iiii that was solved by flipping the button battery. Also, if possible, try connecting with an ANT+ device if the Bluetooth isn’t cooperating. I’ve had better luck with ANT+ with my 4iiii setup.

Make sure the negative terminal spring is pushing on the battery enough to make contact. Try bending it out some. I’ve had this issue on a 4iiii and a quarq.

I flipped the battery upside down and reinstalled it. It turned on immediately and it back to normal now. Thanks guys!