Workouts 'broken' in OSX app

Hi.
For some reason all my workouts since end on November are not showing correctly in OSX app (latest version). When I click a workout no info will show. The workouts are apparing fine in my browser and on IOS app. Anyone have experienced the same issue?
I should mention that I tried to delete and create a new plan using plan builder. In this process I got this wierd message: “Ouch! We’ve taken a nasty spill!” - using Chrome browser.

Yeah, I’ve had a bunch of issues, but they all revolve around TrainingPeaks workout sync. I don’t know if it applied to TR workouts.

Delete the app. Then rename ~/Library/Application Support/TrainerRoad to TrainerRoad.bak or something. Reinstall the app, and let it fully resync, and see if that clears things up for you. Then you can delete the renamed directory, if all your data is there.

5 Likes

Thanks :slight_smile: - your tip solved it for me.
I renamed the folder which forced the TR to re initialize on launch. All rides are perfectly synced now.

Cheers
Thomas

4 Likes