Workout Creator on Mac OSX Mojave

I installed the Workout Creator on a new MacBook Pro. When opening the app, I‘m prompted for the login credentials. After entering them correctly I‘m prompted for them again and again and the TR Workout library fails to download. However, it is possible to create and publish a new workout from scratch… Can anybody help?

You should probably email support. They are typically fast in their response time and are usually able to resolve your problem within a day or two depending on how quick you are on providing enough information for them to troubleshoot.

That’s what I did already. First troubleshooting attempt failed and I did not hear back from support since then :frowning: That’s why I tried to share the issue in the forum…

Not that this helps… I just installed Adobe Air and then Workout Creator. Launched WorkoutCreator.app and entered user/password. After waiting for TR workouts to download, I quit app, restarted, and it did not require my TR user/password the second time.

If it was me, I would completely uninstall WorkoutCreator.app and Adobe Air. Then download AdobeAIR.dmg, double-click to run installer, download workoutcreator.air, and double-click to install it in /Applications.

Tried the procedure - unfortunately did not help :frowning:

Downloaded Air, Downloaded the Workout Creator. Got presented with the TR login credentials, then i was asked for credentials at API.trainerroad.com. Did anyone else see this? Do i need to create credentials for the API server in addition to my TR credentials?

Do you have a screenshot of this? You should just be able to enter your TrainerRoad credentials the first time, and then the workout library should download and allow you access to the Workout Creator.

This is what i get after i supply the normal TR credentials. Using Mojave 10.14.2, Chrome Browser Version 71.0.3578.98 (Official Build) (64-bit). Fresh install of AIR latest version.

Thanks for any insight you can offer!

Having the same issue on Mojave 10.14.2 with fresh install of Air and Workout Creator 1.5.0. Hope there is a quick solution. Haven’t seen this issue posted and resolved anywhere else.

TIA

Did this get sorted? I’m thinking about going ahead with Mojave but am wary of doing anything that might mess up my set up.

Still working here, not sure what is different for those with a non-working setup.

After cancelling the login a few times, I was able to upload an ERG file and it appeared in my workouts. But any existing custom workouts are no longer in the list. And unfortunately I had quite a few that I tinker with.

Thanks - what age of Mac have you got. Perhaps that has something to do with it. I have a massive distrust of Mac updates as the last one broke my “Keychain” and it will no longer remember passwords and I have to keep logging in all the time now. Mac support were as much use as chocolate fireguard.

Mine is a 2017 13 inch without touch bar.

1 Like

Interesting note. I updated my old computer running Mojave and an older version of TR with the new version of TR. It had already had version 1.5 (pre-Mojave) of workout creator and that still works, However, the version 1.5 on my new computer installed under Mojave doesn’t pull old workouts, asking for the login. Also note that on the old computer with Mojave (TR installed pre-Mojave) picks up the workout I was able to create on the new TR installed on the new computer with Mojave. So this is only a pull problem. Both versions of workout creator are 1.5.

Adobe Air version on new Mac is 32.0.
Adobe Air version on old Mac is 28.0.

I will see if I can get version 28.0 on my new computer to see if there is an incompatibility between workout creator and AA version 32.0.

NOTE: I have posted everything for completeness. If you just want the fix, go to the end of the post and see the bolded steps.

The link to obtain older versions of Air: https://helpx.adobe.com/air/kb/archived-air-sdk-version.html

If someone has cycles before I can get to this, please try uninstalling and reinstalling version 28.0 to see if it works. There are runtimes for 29, 30, and 31. So maybe my approach will be to go backwards to see the most recent version that works.

Adding results of my testing to this post since I just found out I can’t post 3 times in a row:

So this is a real PITA. I was able to get workout creator working again with Adobe Air ver 28.0. All other version 29-31 gave me the same popup login as ver 32.0 but when you enter something the box just reappears. In version 28.0 “working” is relative.

When you start Workout Creator whether from TR or from /Applications, you get the following:

I haven’t a clue what that password is and when I checked the keychain I could find no references to anything within that dialog. After I clicked Deny, the workout creator app started but I was presented with another login.

This time when I login, the workouts pull and I can see everything as I used to be able to. So I think there is some issue with the authentication mechanism or keychain weirdness. Hope this can at least get some people out of a pickle if you mod workouts like I do.

Adding more to this post to fix the above issue:

So I wasn’t satisfied with having to login every time. In an attempt to fix this, I did the following after downgrading to Adobe Air ver 28.0:

If you look in that directory you will see references to the above referenced keychain:

$ ls -1 ~/Library/Application\ Support/com.trainerroad.tools.WorkoutCreator/ELS/
.fl89CB8354
PrivateEncryptedData
PrivateEncryptedDatai
PrivateEncryptedDatak
PrivateEncryptedDatav

Looks promising … delete:

rm -rf ~/Library/Application\ Support/com.trainerroad.tools.WorkoutCreator/ELS/

Now go to TR and start workout creator again. It asks for login, then it asks again “I think the keychain part”. I entered the same thing both times and checked the box to save in my keychain. Restarting TR several times seems to no longer throw any errors or require login.

Will now try upgrading Air since ver 28.0 is circa Nov 2017 (i.e. vulnerable to something). The procedure of removing ELS dir could also fix the issue for those on ver 32.0.

Response to being able to fix the login problem directly in ver 32.0

I tried upgrading straight to ver 32.0 and started getting the login prompts. I deleted the keychain stores again and went thru the process of re-entering the passwords and saving the credentials to the keychain. Workout creator put the workouts there which were loaded from the ver 28.0 fix. However, the login prompts still appear. So either workout creator needs to be updated to be compatible with later versions of Adobe Air or Adobe Air is broken.

Final solution (no need to reinstall Workout Creator):
1. Downgrade to Adobe Air ver 28.0
1a. /Applications/Utilities/Adobe Air Uninstaller
1b. Download ver 28.0 here: https://helpx.adobe.com/air/kb/archived-air-sdk-version.html
1c. Install ver 28.0.

2. rm -rf ~/Library/Application\ Support/com.trainerroad.tools.WorkoutCreator/ELS/

3. Run TR and open Workout Creator. Then enter your creds.

4. You may or may not be asked to enter them again in a popup but if so enter them and check the save to keychain when that option appears.

5 Likes

Hey,

I ran into the same issue last night.

Thanks for posting this fix. I worked back from V32 to V28 and ended up stopping at V28 (cuz it worked).

It’s pretty rad to have a member post such an in depth work-around.

1 Like

Glad this works for others. Hoping TR addresses this in a new WC release.