Website workout search levels wrong?


Apologies if I’m losing my mind. When I search workouts, the progressions levels shown on the search results don’t match the progression levels when you click on the workout. See below, for Raymond.

Anyone else seeing something similar?


I reported something similar a few weeks back when I searched for a low lever SS workout on the website Big Fodderstock came up as 2.5 but when I went into it, it displayed 5.3.

Big Fodderstack PL inconsistency - TrainerRoad Software - TrainerRoad

Edit Androiid seemed to have it right though :exploding_head:

yes, I ran into this just this morning looking for a SS workout. where do we report?

Emailing directly to is always a great place to start.

Hey @dchapman5678 !

I’m taking a look into this for you just now. I will circle back around when I have more info :slight_smile:


Big Fodderstock is still the same as is Vancouver -2; PL of 2.5 in the search for a 1hour long SS workout but a PL of 5.3 in reality. I wouldn’t be surprised if others are the same @SarahLaverty

done! thx

Many thanks!

Thanks for the reports, guys. I spoke to the team, and we have passed this along to the developers, who will sort this out for you guys.

Thanks for your patience!

1 Like

I’m wondering if this is related to WLV2 somehow showing up a bit early in some areas… I was taking a look at Disaster for WWDD, and it had a threshold rating of 10.4 (I didn’t screenshot it, that’s from memory - don’t quote me). Had this same/similar issue with weird workout levels showing up this morning, then gone after I refreshed the page a couple hours later.