Wahoo Power Smoothing and offset

Is there a way to display the actual power data from a Wahoo Core without smoothing? I have turn off erg mode power on the Wahoo App, but I am still seeing that perfect line when I’m doing my workouts?

Also, the Wahoo Core is reading ~50 watts lower as compared to my Quarq across the power range that I tested (100/150//200). Is there a way to offset the power reading from the Wahoo without a power meter? There is a manual offset in the power match, but I guess that only applies if I actually have a PM on the bike? My trainer bike does not have a PM and I do not wish to put my outdoor bike on the trainer.

I am in the midst of getting a replacement unit from Wahoo, but looking for a stop gap solution in the meantime so that my TSS does not goes out of whack with the different FTP/power readings between indoor and outdoor.

1 Like
1 Like

Hmm, i did turn off the erg mode power smoothing in the fitness app, but I’m still seeing perfect lines. Does the app need to be turned on while doing my workouts in TR?

1 Like

I would not run the Wahoo app at the same time in general. It might be OK if you are connecting via ANT+ in at least one connection. You can only have one live BLE connection at a time. So, I guess that could be an issue.

I’d make sure to only be connected to the Wahoo app, verify the setting, then close the app. Then try in TR and see what you get. When it’s right, you will get the normal jagged power lines.


So I’m now pairing my Vector3s as the control power for the Kickr Core. Vectors connect to the Kickr via Ant+, Kickr reports power to TR via BLE. I have erg mode smoothing turned off. Vectors still report cadence to TR via BLE. And I’m getting pretty smooth graphs. Not as smooth as some I’ve seen but… Power appears to have a 3s or so smoothing effect on it. RPE at threshold and VO2max seems the same, but I do miss my actual representation graphs.

I switched this setting at the suggestion of Support, as they said many users get a better experience from the ANT pairing to the trainer, and then the trainer reporting power rather than directly using PowerMatch as I had been. I changed this setting after another instance of the Vectors failing to report power in TrainerRoad. The control power was was still there, but TR read 0W.

Anyone have any idea what the default smoothing is in a case like this? Again, in the Wahoo App erg mode power smoothing is off; Vectors are controlling power via ANT+ to the Core (not via Powermatch).

1 Like

I have my Stages LR paired to my Kickr 17 using ANT+ as well, and I have noticed that the graph is much smoother than using my Stages LR and powermatch through the TR app. Not dead smooth like using the Kickr with smoothing turned on, but still what seems artificially smooth.

That being said, I have found that using the Stages to control the Kickr through ANT+ has given me a much smoother experience overall compared to powermatch.

Yeah, the graph doesn’t really bother me, I guess. The apparent smoothing of the TR-reported power is more of a nuisance than the graph, anyway. I don’t think it’s impacting the workout.

Ok, so i found two smoothing controller:
One @ my Kickr App (Button on/off) and one in the TR App Settings ( controller to set the seconds of smoothing ).
@mcneese.chad ok, not run both apps together :white_check_mark:
But whitch setting shout i choise. what is better, the clean smooth line or the
jagged one? Is it just a display setting? because if i smooth or not, in my power2max build in powermeeter its always the same, doesn‘t matter what i choice. what is the reason to smooth a workout or don‘t.

thank you for your help

I suggest Wahoo “Erg Mode Power Smoothing” set to OFF:

I suggest TrainerRoad “Power Smoothing” set to from 3-10 seconds. This is very much a user preference, so play with it and see what you like.

  • But most important to recognize about this setting, it ONLY AFFECTS the 3-Digit Power data in the display. It has absolutely no impact on graphing live or afterwards, and it has no impact on the results when reviewing the completed workout.
  • It is just a tool to keep the current Power value from bouncing around so much that it messes with our head.



perfekt @mcneese.chad
i will try this @my next workout


@mcneese.chad @ellotheth

So i turned off smoothing on the Wahoo-App and i put the controller in the TR App to „3“ (before it was on 5).

The Power-Graph was still pretty clean. In the end of the programm when i was pretty tired the graph starts more to be jagged.

Below my build in power meter raw data-graph

The TR graph still looks like ERG smoothing on the Wahoo app is turned ON. Also looking at the variation in your cadence e and the lack of correlation to Power graphics, is another indication that ERG smoothing is probably ON.

Here is my recent ride on a Kickr with no ERG smoothing.

I switched ERG-Mode Smoothing off in the app :man_shrugging:t3:
Will check this next time again :nerd_face: