Wahoo Kickr Erg Mode Missing

My Wahoo Kickr no longer has Erg mode or any other resistance levels available. What happened to this functionality?

Make sure you have chosen the smart trainer activity icon. If you choose the bike icon the smart trainer controls are not present.

1 Like

Is this related?

1 Like

Yes, thank you. Did the firmware update, restarted my Microsoft Surface, and that solved the issue for Erg and Resistance. There used to be a third option but the name for the option escapes me. That one is still missing from the drop down box in TR.

Unrelated but I had to “forget” and “find” my Quarq power meter on my Wahoo Bolt after the firmware update as well.

2 Likes

The 3rd mode was “Standard” and it is not available with the updated ANT+ FE-C protocol, now used by TR.

Hello all–my ERG setting is also missing on my windows laptop using trainer road. I looked at the firmware option for updates but it’s all for phones, correct? How can I get this updated for my laptop? I am not very tech saavy but I want to spin!!

1 Like

Hi @swanson28 do you have a Wahoo Kickr/Snap? You need to use the Wahoo app on your mobile to update the firmware. Let us know if you have questions!

My kickr is updated, I still cant use ERG mode. and I dont know if my trainer road updated itself and thats whats causing the issue.