TR does not pick up HR from HR monitor for the first 20 minutes of a workout


I have been experiencing the following. After 2/3 workouts where TR correctly reported my HR from my polar H10 during a workout, now for the first 20 minutes it does not. When I begin a workout HR starts counting from 1 and slowly goes up to 250 or so. Once it reaches that level it drops down and links up to the Polar, beginning to report the correct reading during the workout.

During these first 20 minutes, however, the Polar is correctly detected, and under ‘devices’ you can see it working correctly, with the accurate HR reading displayed. But TR simply ignores it for the first 20 minutes or so.
It’s quite annoying as TR is connected to my Garmin Connect, which now thinks my heart has gone crazy, with cascade effects on all my other fitness metrics.

Anyone experiencing similar issues?

1 Like


I doubt that TR is just making up numbers until the H10 connects - more likely that those are the numbers that the H10 is reporting.

I would start by making sure that the sensors on the strap are damp and that the battery is not almost empty.

EDIT: I missed this bit :thinking:

I would definitely reach out to TR support on this one

I’ve been experiencing this as well, have you found a solution? My heart rate device is a wahoo.

Hey @FdM :slight_smile:

We’ve already sent these troubleshooting steps to you via email, but I’ll list them out for @Ednut to try them as well:

Firmware Updates:

Let’s make sure your Polar H10 has the latest firmware updates. Often times these updates have various fixes that keep your device running smoothly. You can find directions on ensuring your firmware is up-to-date here:

Polar H10 Firmware Updates [CLICK].

Reset Heart Rate Sensor:

To reset your heart rate sensor:

  1. Remove the battery.

  2. Press the metal snaps that attach to the strap with your fingers for at least 10 seconds.

  3. Wait 30 seconds, and then put the battery back in.

Battery Usage:

Let’s make sure the batteries in your H10 are brand new; this will help rule out any power issues.

Restart Your device running TR:

Restarting your device will ensure we start with a clean slate and can help if anything gets into a bad state.


Check that the heart rate monitor is not connected to any other app or device. Having it connected somewhere else might lead to issues with the way it communicates with TrainerRoad.

Finally, let’s go ahead and uninstall and reinstall the TrainerRoad application in case there is corrupt data or something got into a bad state. Not to worry, all your data will be saved in the cloud. You can download the latest version of the app here:

Let me know how it goes!!!

1 Like

Yes I’ve has similar with my Tickr. Following steps have always resolved the problem

  1. Lick the contacts on the strap before putting the HR monitor.
  2. Wash and dry the strap.
  3. Replace the battery
  4. If 1-3 doesn’t work replace the strap
  5. If 1-4 doesn’t work, replace the Sensor pod.

Thank you for the input @JonGreengrass! These are great steps as well!

Hi Caro -

Unfortunately these suggestions didn’t solve the problem. The Polar was fully up to date with a full battery.

As I specified in my email to support, my Polar H10 is listed among the devices that TR sees, and under ‘devices’ you can see the Polar reporting the correct HR. It’s just that TR, for the first 20’ or so, doesn’t source the HR measurement from the Polar H10, even though it can see it. It seems to source it from the indoor trainer that I use, which in the list of devices is showed as reporting an HR that progressively goes up from 1 to 250, in the space of about 20 minutes.
This morning I managed to have TR link up with the Polar right from the start by doing the following: I started the workout by beginning to pedal on the trainer, instead of pressing the ‘play’ button at the beginning of the workout. I don’t know why, but I tried this procedure twice and it worked both times.

I hope this is a permanent solution!

That’s interesting - what trainer are you using that reports heart rate? :thinking:

Have you ever paired a heart rate monitor directly to your trainer? I think some tacx and wahoo trainers allow this…but I wouldn’t recommend it.

Sounds like your trainer is pumping out a random number which is taking priority :thinking:

Hi Kevin,

I think that’s exactly what’s going on, the trainer is pumping out a random progressive number which gets picked up by TR instead of my HR monitor. To avoid that I need to start the workout by pedaling instead of pressing play on the TR app. God knows why, but it works and I can live with that.

I have an indoor trainer from VirtuFit ( which I’m not sure it sells in the US. I live in the Netherlands and that’s where I bough it. It has HR sensors on the handlebar, but apparently even if you don’t use them it sends out some signal through Bluetooth which is picked up by TR.

My HR device appears to talk to my phone intermittently so I get broken HR readings on TR on the Laptop. I turn off the Bluetooth on my phone before I start workouts and it connects fine and reads consistently all the way through

1 Like

Neat looking trainer…

I’d be looking for a setting on the trainer or it’s app to either turn off sending heart rate or (go against what I said before) see if it’s possible to link your H10 directly to your trainer

I doubt TR has implemented an option to not use the heart rate being sent from the trainer, could be wrong. If they have it would be under the settings menu for the trainer that you get to via the “devices” menu.

1 Like


For me it is all about the lick. If I lick the straps, this doesn’t happen to me.

1 Like