Strava sync error when ride duplicate

I use a Tacx Neo trainer with a TrainerRoad on an iPad as my everyday setup. Works great.

Today I ran my Wahoo Element during a TrainerRoad workout so I could compare power between my Tacx Neo and a crank power meter. After the workout both TrainerRoad and the Wahoo Element synced the ride to strava, but the Wahoo got there first and therefore seems to have cancelled out the TrainerRoad one.

I’ve since deleted the Wahoo ride in Strava and tried “resync ride” multiple times in TrainerRoad, but I just see “Sync Error”. My ride has not appeared in Strava for the past few hours. Any ideas how to fix this?

Hey @mkonecny, I’m working on this now.

I’m not seeing any TrainerRoad files on your Strava. Do you typically delete them once they’ve synced over?

Hey @mkonecny,

After lots of digging, It looks like there is some sort of stuck data on Strava’s side that’s preventing us from pushing the original ride through even though the original ride has been deleted on your Strava.

At this point, you could either reach out to Strava to see if they can find this problematic data and remove it, or manually upload the workout to your Strava account.

Sorry we couldn’t do more on this one. :smiling_face_with_tear:

1 Like

Il reach out to Strava. Thanks!

1 Like

Let me know what you find!