Stages bike --- >TR connection issues

I am having some issues with TR, specifically I am having issues where TR is not adjusting the resistance on my SB20 stages bike. I completely factory reset the SB20, the crank arms and it’s still causing problems. I’ve previously used it in erg mode with no issues however more recently either the software is displaying incorrect power data, e.g. I tried to pedal at 67w for a basic warmup, and it will sky-rocket to 110w before remaining there, and the ergo isn’t kicking in, or it will sometimes not register any power at all, or under-reporting the power relative to my actual cadence, which is unsustainable because I’m spinning out at 30w, it will then gradually creep up to the desired warm up power before remaining there. It’s like the software is not talking to the hardware, or visa-versa.

The SB20 appears to work in stages link/power and are calibrated/off-set there.

I have emailed both TR support and stages but has anybody else encountered a problem like this? I’ve tried all the recommended support suggestions, e.g. factory reset the SB20, crank arms, software reset, tried the software on two different devices, but I’m completely stuck.!

Are you only connected to the Stages bike in TrainerRoad using either BLT or Ant+, but not both? Also, are any other devices connected to the bike? If so, close them out.

To help diagnose / provide suggestion, it would help if you provided:

  • Firmware version on your SB20
  • what device are you running TR on

My Lenovo tablet has both Ant+ and BLT, and my iphone only BLT.

Usually I also have my TICKR connected but I’ve been testing without it.

The device is a lenovo android tablet, not sure exactly what it is but up to date running the latest android OS.

the bike firmware is the latest version 1.12.0+3558

Include a screenshot that shows what devices TR is connected to.

Dumb question, but just to rule out the obvious: the bike is set to “external”, not “erg”, in the Stages Link app, right?

1 Like

Tried setting to external in the app, and now instead of massively out of sync power data I’m getting nothing at all when pedalling.

When I first used the SB20 + TR, I did not set external before and aside from calibrate/updating the firmware on the bike and pedals. I left all settings on SL as stock.

This is what my TR app is connected to.

Leave it set to external. Erg mode on the Stages Link app means that app’s erg mode, not TrainerRoad’s, which caused similar issues for me when I first set mine up. External means TR, Zwift, etc. can control the bike.

In your screenshot, looks like the TrainerRoad app can see the devices, but is not paired to any of them. Can you tap on the first one (Stages Bike 0070), hit pair, and see what happens? You might also want to try replacing the batteries on the power meters.

Hi, I’m new to TR and just signed up this week using my SB20. For my first workout I did the tramp test and everything worked flawlessly. The next day I picked a workout and had the exact same issue. The warmup target was 80ish and the most I could do was in the 30s. I’d spin like crazy but the resistance never kicked in. I tried different workouts, doubled checked all of the settings, rebooted my phone… Finally I unplugged the bike and plugged it back in after 30 seconds. Everything worked after that.

In addition, make sure you aren’t connect to the pedals - “Stages 1128” & “Stages 46887” - in your screenshot. This is key with the SB20: ONLY connect to the bike. Stages actually built its own power match into the SB20, where the SB20 power is being matched to what the pedal power meters report.

I speak from experience on this: when I first got my SB20, it was before TR removed power match for the SB20 in the app, and I tried to use power match - god awful mess. Plus I also paired the pedals instead of the bike - again, horrible experience. Some Googling set me straight, and since then, all good - except for a few times that appear to be either 1). low battery levels in the pedals; 2). too many wifi / bluetooth devices showing up

It can see the devices and I’ve paired them. I’ve also replaced the batteries in both crank arms, ‘forgotten’ the devices on TR and then repaired them but no dice.

The green outline on the apple OS TR is faint on the screenshot but is definitely paired. Some screenshots below.

Ah, I’ll give that a go and see what whether that rectifies the issue.

I just tried pairing only the SB20 in TR, it’s not detecting any power output from the pedals unless I’m doing excessive amounts of power.

TR should only be detecting power from the SB20 bike - it should only be interacting with the SB20 bike. So the power that TR displays should be from the SB20 bike.

The way the SB20 works in ERG mode - say you are doing a 200 watt interval - with TR is the following:

  • TR sends the SB20 bike a requested power - 200 watts in this example
  • The SB20 bike receives measures from the SB20 pedal power meters
  • The SB20 bike then varies the amount of resistance so that the SB20 power meter pedals registers 200 watts

Effectively the SB20 is doing a private version of what TR power match does.

I’ve been engaging with the TR support team and we have exhausted all avenues of troubleshooting between stages bike and TR. It appears that, with the discovery that erg mode in Stages-link is not working either, that it is likely a fault with the bike itself. I was able to comfortably put out well in excess of a 100w erg threshold without any auto adjudgment in stages link. It seems that, whilst it’s detecting power on both SL/TR there is no ergonomic adjustment of the resistance based on my cadence or power output on the bike itself. This is with just the bike paired, and the bike fully reset numerous times including both power meters and the bike firmware.

I suspect it will be a warranty replacement or a job for a visit by a technician, but we will see.

Good luck. My last suggestion, if you haven’t tried this already, is to replace the batteries in both pedal power meters. I’ve seen weird behavior if the batteries are low.

Stages are sending out a replacement part for the SB20 that controls the erg/resistance, fingers crossed this solves the issue!


Sadly, installing the part last night gives the same behaviour. Power is detected but there is no erg mode resistance adjustment as per the set value in stages-link, or any plan in TR. I’m only paired with one device in my troubleshooting efforts. The bike, and the meters are detected in Stages-link, stages-power and are calibrated/updated/zero’d to their maximum.

It’s frustrating as previously it worked perfectly out of the box and was about as plug and play as you could get. Earlier in 2021 I had to get a warranty replacement on one of the crank arm meters as that was not being detected and appeared to have died (after a battery replacement). It then worked again for a period of time before this issue arose.

The troubleshooting continues…

:cold_sweat: :astonished:

I’m so eager to get back indoor cycling that I’m tempted to just buy an emergency alternative trainer in the event that I am unable to use my SB20. :sweat_smile:

My worry is that, if can’t find the issue with it that it’s going to be a like for like warranty swap. I don’t know if stages employ any UK visiting techs but i suspect it will be a long while before I get it, if so.

I had pretty much the same issue on my new SB20 - resistance was way too high for the TR power target. I replaced both power meter batteries (the original ones were measuring 2.8v whereas new ones measure 3.2v) and that seems to have resolved the issue. You’d think for a €2650 bike they’d at least give you new or spare batteries (they’re only a few euro for a pair!!)