Something went wrong error

Have the latest Mac Mojave update with latest trainerroad. I’m getting “something went wrong” error today. Have to close the app and restart it a few times before it works. Tried reinstalling software with same issue. When looking at ping logs, trainerroad servers seem to be timing out. Never had an issue before. Anyone else having problems this morning?


Same issue on windows.


Just worked after 4 or 5 restarts :man_shrugging:t2:

I am having exactly the same issue. I had it though just before doing the Mac update and thought maybe it was connected to the the fact I had not done the update. Post doing update, however, it is still doing the same. It may therefore be just a coincidence and a general issue with the server ?

Lol mine just started working also :+1:

Same problem here. Cannot login on the iOS app.

Update: works after a few retries, but workouts are not pulling from the calendar properly. They pull with no icon and today’s workout won’t let me start it - only gives an option to view it online.

I have Windows 10 Pro and the Trainerroad Windows desktop app crashes as everyone states above…

I tried unistalling and re-installing but the issue persists.

The Android app works ok. I will try to do my training on the 5" screen lol

1 Like

Windows 10 - can’t log in

“Something Went Wrong”

I use ANT and won’t have much feedback if this doesn’t clear up.

Edit: iOS app on iPhone8 is working/loading ok.
Edit: iPad Air unable to Log In

Same Issue here. Uninstalled and reinstalled twice even restarted MacBook a few times.

Same issue and message here on Win 10. I noticed post workout sync issues on 7th Jan, but that synchronised eventually, same today except restarting the App now fails. Mobile (Android) ok, website ok.

I’m sure Nate and the crew are all over it …

Force quit the iOS app because things weren’t loading. Now it’s asking me to login and login isn’t working. Smells like server troubles.

Seeing the same error on MacOS 11.1. I’ve been able to get it loaded on my iPhone 11 Pro on iOS 14.3.

Looks like it’s going to be a small screen day

Mac 11.1 here, same problem. Can’t even get into app, just the spinner while the app tries to open, then the same screen as gbraithwaite above. Hopefully can still download app from Apple app store. I’m fortunate that all my gear is dual ant/BT. If I had an ant-only device in the mix, I’d be dead in the water.

Same here on Mac OS 10.15.7, haven’t done the recent update yet. Restarted the app many times without it functioning.

I turned my wifi off on desktop and am using it offline mode and all seems to be working.

Edit: To be clear, turned off wifi, then relaunched the app.

1 Like

Getting the same errors on the iOS beta and Windows beta versions.

Same issue here. I’m new to TrainerRoad, I hope this doesn’t happen often.

Not often. In the 3 years I’ve used TR, this is the first time.

Same issue here!

Same…so much for getting it out of the way in the morning :pensive: