Ramp Test: Fluctuating Power with Wahoo Kickr

I have done two TrainerRoad Ramp Tests using a Trek Top Fuel mountain bike mounted to a Wahoo Kickr (in ERG mode). During both tests, I had a difficult time keeping the power smooth and at the desired ramp level. I was above the desired level just as much as below (until the last step, of course!).

I am very familiar with the stochastic nature of riding with a power meter outdoors or on a trainer in resistance mode. What I’m not familiar with, and what I don’t understand is why the power fluctuates so much on a trainer set to ERG mode (and using a consistent cadence +/- 2-3 rpms).

What am I missing?

Do I need to select a different setting in TR or in my Kickr app? Maybe Control w/ ANT+ Power Meter (which has not been selected during either of my previous tests).

Any suggestions?

Thanks in advance,

Links to the tests:

Ben

Can you share links to the tests for review? Better for us to see the fluctuations and other data to make any suggestions.

What gearing were you using exactly, for ERG mode?

Thanks for the reply, Chad.

Links to the tests added to the original posts. As for the gearing, my mountain bike (the only bike I own) is a 1x12, so I typically use 32x10 or 32x14 (something big enough to get the flywheel going).

I’ve tried using easier gearing during other types of workouts, but something feels “off.” In easier gearing, I feel the Kickr “pulsing” the resistance (if that’s the right word - sort of dramatically increasing resistance and then releasing it just as dramatically… hard to explain).

I attributed that (perhaps mistakenly so) to the lower gearing of a mountain bike not getting the flywheel spinning fast enough to “smooth” out the power being applied by the trainer.

1 Like

OK, I have more to add, but a few quick notes.

From the workout, it shows you are using a “Quarq Power Meter”. This is important to know, because a typical power meter will respond and show more “spikes” and variation in power compared to many smart trainers. This matters since the constant fluctuation can cause people to over-react to power targets and make things worse (more to come later). Also, what is your “Smoothing” setting in the TR app?

Gearing at the max end of your setup sounds right to me. I think that is good.

Considering you have a power meter AND smart trainer, we may need to clarify if you were using Power Match in the TR app. Also, which exact version (device and regular of beta of the app) you were using may matter. I haven’t followed closely, but Power Match has been revamped in some app versions, and has a new option to experiment with. I know just about that much, so we will need to pull someone else in to cover that in more detail.

If I were to make a snap judgement, I suspect you are “chasing power”. What I mean by that is that you are watching power, and potentially trying to make it higher or lower with cadence. I could be wrong, and know you said you keep a steady cadence. But see some cadence trends in your tests (100+ for lots of the first test, then degrades and bounces) (start around 90 and end around 100 in the 2nd test). Ideally, I like to see people set their cadence at the first few steps and hold it +/-5 rpm until hitting the failure point. You have swings in opposite directions in each test.

All that is to say, ignore power. Just focus on your cadence number… let the app and trainer do the work of setting power. Watching power will only derail your actual results, from what I have seen.

2 Likes

My smoothing setting is set to 5 seconds.

I looked up Power Match, and I see where you go to turn it on within the app; however, I do not see it as an option under Device Settings. Maybe that is because the power meter is off right now (I’m in my office with my bike/trainer/power-meter in the garage). Is that something that only becomes available in the app when the power meter is detected by TR?

I’m using the TR app on a Microsoft Surface.

Yeah, Power Match only shows as an option when you a Power Meter AND Smart Trainer actively connected in the devices.

Definitely looks like some sort of latency happening, as the problem is unaffected by power level.

Either that or you’ve placed your trainer setup on a trampoline.

Start removing variables to zero-in on the problem.

  • Make sure your power meter is not connected to your device. Only connect the Kickr.

  • Try a different device like your Smartphone

  • Get off the trampoline and ride on solid ground

1 Like

I actually think the power graph looks pretty reasonable. The full view is misleading, IMO, with the zoomed in view seeming decent to me:

Full view, Feb test:

Zoomed in to the extra bump section identified above:

Sure, that one above is more bumpy than earlier sections below (same time scale as above):
image

But I think the middle pic just shows the fatigue and variability in our performance through the harder steps.

1 Like