Powertap P1 Pedal Issue - Cadence only no power

I’ve had a pair of P1 pedals for several years with no issues. Yesterday I removed them, lubricated, installed new batteries, and when I set them back up I am now getting no power reading. The pedals connect fine via BLE and ANT+ to my phone/Garmin but power stays at 0. Strange because cadence readings are accurately coming through so the things are working and connecting fine. Even when I perform a zero offset a non-zero number appears which leads me to believe the power sensor is working? Any ideas to fix? Or is it finally time to dump…

What exactly do you mean by “removed them, lubricated”?

removed them from the bike and cleaned and added new grease to the threads where they attach to the frame.

OK, just making sure you didn’t disassemble them, which is not a user service option.

If you haven’t already tried, I’d test connection with multiple devices/apps (head units, phones, TR app, etc) and see if you get the same “no power data” everywhere.

Yes I’ve tested with my Garmin head unit, Garmin watch, TR iphone app, and paired with the SRAM app (and confirmed updated firmware). All show zero’s for power but do show cadence.

Got exactly the same thing yesterday. Did you find the solution ?

Maybe you installed a battery backwards (or even a dead battery), are you getting green lights on both pedals? I know when I swap batteries or bikes it take a minute or so for power to re-sync properly.

Today I ve tried, new lithium battery, swapping caps, pedals are up to date… when I put a new battery, the green light is on but after 3/4 minutes no more battery. If anyone experienced the same thing pls let me know

Are you using non rechargeable lithium batteries?

Yes. But actually when I put a new battery the green light is on for 3/4min an then nothing. If I put the same battery again same thing green light…

I had major issues with my P1s and even after a return to the authorised service centre for a full (expensive) rebuild it only partially solved them - might be related…

They claimed the crux of the issue was that leaving batteries in for even a short time after they run down causes minor leaks that mess with the electronics. They claimed the leaks weren’t necessarily visible on the batteries or in the pedal but the damage gets done. I tried their initial fix of a long period in a warm dry environment and it temporarily solved the issue but the issues soon returned. I had similar symptoms to you but also had problems with the zero’ing functions. The only fix was the full rebuild and even that didn’t fix the issue that one pedal would never go to ‘sleep’ mode any more and would drain the battery in no time.

What was really annoying was that the pedals had extremely light use as they were bought for use on a couple of trips and covered <1000 miles but because they hadn’t been used in a while the warranty had expired. Turned out to be a very expensive porr product as even after the full rebuild they still give occasional issues and I really wish I’d never bought the bloody things.

Thanks Bigpikle !!! Regarding the price of quarq support services I better buy a pair of favero…

yep - the dealer that sold me the P1s originally recommended I replace them with the Faveros…I’m waiting for the new Wahoo Speedplays instead though.