New KICKR Core - a few questions

I was lucky enough to win a KICKR core last week (especially lucky given my Saris M2 is currently away for a warranty claim) and have been using it the last couple of nights whilst doing some basic endurance riding. I have been comparing the power to my Stages left sided PM and I’m a bit perplexed why the power plots are so different.

I wasn’t expecting them to be exact but I have been using the Stages for quite a few years and believe it’s been very consistent. I wasn’t hoping to keep the Stages on my winter bike and use a different bike on my KICKR using that as the power source.

But things seem quite different in terms of power tracking I’m a bit confused.

Something I’ve also noticed is the time. By the time I end a ride, the clock on Zwift is about 8-9s behind my wahoo after 90 minutes for example?!? Could this be a factor?

Can anyone offer any input?

Kickr Core is +/- 2%
Stages Gen 2 is +/- 1.5% claimed (but there is a reason that Stages has the reputation of being a “power estimator”)

So this is a little outside the bounds, but not by a massive amount.

There are ways to reconcile this at the file level but its a pain, so honestly I’d recommend just using one power source or the other for the winter.

1 Like

I know Stages reputation can be a bit hit and miss but I’ve been using it for over 6 years and sense I know enough to know if something is not right.

Testing, intervals etc have always been as expected. Not had any shocks in the past.

I did some power testing with my Stages 2 weeks ago so just wanted to have confidence the KICKR is close enough to ditch it for indoors.

It’s not so much that the Stages Gen2s are “imprecise” or “inconsistent” it was just that the accuracy was highly variable across the various lines. You may have a good one! My Gen2 was very consistent, but just reported 30w too high.

Honestly we have no real ability to know if the Stages or the Kickr Core are “correct” unless you had a third power meter to compare against.

If you had a friend who had another trainer or a pair of power pedals, you could run a test to see how it triangulates.

IMO, its right on the line where its probably ok to ignore it.

1 Like

You didn’t state any calibration steps, so make sure you are doing those, if you haven’t already done so.

Keep in mind the pure basics:

  • Left-side measurement doubled (Stages) vs full power measurement (Snap)
  • Crank location derived power vs rear tire derived power. At a minimum, drivetrain condition & related loses could be a factor.
1 Like

In this instance the trainer is actually higher, which is interesting. I’ve also experienced a similar thing recently.

We honestly have no idea if companies are calibrating behind the scenes to match power at the cranks so its tough to unpack.

1 Like

Hi Chad, did a spin down yesterday and calibrate the Stages every ride.

Might try another spin down before my next session.

1 Like

Yeah, I get lost in the whole (this should be higher/lower than that…) discussion. Just wanted to point out that people often ask the question while not stating that there are clear variables at play, regardless of the up/down impact.

Honestly, it all makes my own head spin :stuck_out_tongue:

1 Like

Could be worth trying a Factory spindown too, if you haven’t.

1 Like

Thanks for the links! I’ll try that.

1 Like

Hi

Not sure if anyone can help here? I’ve decided to use my Stages PM for now but a bigger issue seems to be the lack of resistance on the KICKR (in this instance I’m using Zwift).

I was doing a tempo workout (in workout mode) tonight, (Stages paired for power and cadence, trainer control off). I’m literally in 50/14-12 etc to get any kind of resistance, so when I look to do some low cadence drills it’s impossible.

My Magnus M2 trainer id be in 50/25 or 23 etc and I’d be able to find a cadence or power level as and when required.

No idea what is happening with the KICKR :man_shrugging:

  • Why? This would seem to be your issue.

Normally I have trainer control off as I don’t want ERG mode, should I have trainer control on but deselect ERG mode? I realise in workout mode gradient changes don’t happen anyway but as mentioned this was what I did with the M2 and had no issues.

I’ll add that in general riding mode, Stages paired power and cadence and trainer control off I have the same issue. So if I want to ride at a controlled wattage (no gradient changes etc) I’d still be suffering from low resistance. Ok if I want to ride at 225W but virtually impossible to ride at lower cadences etc. However if I sprint, then suddenly the resistance will jam on!

  • Yes, you want trainer control on in Zwift, assuming you are USING Zwift as the only app. With it off, you have nothing controlling the the trainer at all, and that is the reason for your runaway pedaling. Connect it for Controlled and you will have a much better experience with the option to use Resistance or ERG in workouts.

  • You only leave the trainer control off if you are using something like TR to run a workout, while also using Zwift for distraction.

If you use Zwift on it’s own, always have the trainer control on. Select your trainer mode as needed (ERG VS RES) in the workout selection, or in the Companion app if you want.

  • Yes, because you have not paired the trainer to be “Controlled”. It is all working as expected, because you aren’t setting it up as intended.

I’ll bow to your wisdom here but this is not how I have done things before.

Maybe repeating myself here…

Sorry if you answered this above but if I want to ride in Zwift (only Zwift) without gradient changes so I can focus on riding at consistent power, I have just had Stages connected as power and cadence, trainer control off and have had all the resistance I need across the cassette. I’m talking the full range from 100-1200w. But if I do that now and I begin the ride around 200W I’m already almost out of gears and at a decent cadence, say 90rpm. Previously on the Magnus with it set like that I’d be in 50/25 not something like 50/14 etc.

This I do not get.

OK, you are talking about a non-typical use case for sure. Let’s ignore Zwift all together to simplify your goal.

You simply want to have the M2 run like a “dumb” fluid trainer, with a reasonable “fixed resistance” curve that allows you to set your effort with gearing?

If so, there was the option for Saris trainers (for sure on the Hammer series which I have used, and also the Magnus series if I understand right, but have not tested) to use it in “Headless Mode”.
When you have the trainer powered, but not paired to any device or app, it should act with a curve similar to their Fluid2 trainers.

It sounds like you may have experienced this in the past. If so, have you updated firmware on the trainer since then? It’s possible that a FW change may have messed that function up (assuming that is what you were getting).

There may be other ways to get this function, but I will leave those out until we make sure I understand your goals.

Sorry if I confused the issue but these issues relate to my new KICKR core, the Magnus is currently being fixed :grinning:.

But, the way you describe my experience with the Magnus is spot on:

I was expecting the KICKR to behave the same but clearly not. But if that’s the case then it’s really not going to be the experience I’m after. This doesn’t seem right.

1 Like

I should add there will be times when I want to have gradient changes (racing etc). But mostly I need it as discussed. On those occasions I’ll have trainer control on.

1 Like
  • Different brands do different stuff. Not all offer the same function or options.

Right, the Kickr does not offer a “headless” version from what I understand. What you can do is access the Kickr with a mobile device using the Wahoo app or a head unit, and pair it as a smart trainer. Once that is done, you probably would like using the “Level Mode” to get the results you want.

Fitness app control:

Head unit control (may or may not be an option in Garmin too?):

General info on the Level power curve:

In either case above, you need an external control to the trainer to set it in that mode. There is no default “headless” mode like Saris.

1 Like

Thanks for this, using the wahoo app or even using my BOLT to alter the resistance setting could be the way to go. Hopefully it’ll not clash.

Really appreciate the help. Thanks.

1 Like