Missing Standard mode after upgrading software

Last week I updated Kickr Core software via android app, which I rarely use as prefer TR on computer. Since then I’ve lost standard mode, just ERG and Resistance remain. This has resulted in me having to use ERG for some workouts and switch between the two on others. I can’t do a spindown as there is no standard mode and the speed does not register in TR. I’ve tried a number of options, spent a couple of days trying, rebooting everything, switching between Bluetooth and Ant+, removing all other bluetooth equipment, with no return of Standard mode. Anyone got any suggestions before I throw the lot out!?

This sounds the same as an issue I’ve had with the Kickr v5 and TR, due to the Kickr now supporting Bluetooth FTMS connectivity, which does not support standard mode. I’d recommend contacting TR support to confirm, but you can also try downgrading your Kickr firmware:

  1. Unplug the trainer for 10 seconds
  2. Open the Wahoo app
  3. Make sure the Wahoo device is powered on
  4. Click on the Wahoo device when it pops up
  5. Wait for the Wahoo Device to connect, once connected tap the blue button to connect. At the next screen at the top tap 10 times on the little black icon of the Kickr to bring up the firmware update list. Choose the previous public firmware version.
  6. Allow the update to finish

When I had the issue it was only in the windows app, the Android app still supported standard mode, but I’m not sure of the current status. Definitely worth checking in with TR support for more info.

1 Like

Thanks will try it out. Seems like a referral to consumer protection coming on :frowning:

Yep, this’ll be it.

I wish TR had slope support (FTMS Inclination and FE-C incline), but it’s not in the cards.

Thanks guys, worked a treat now Standard mode is back. Guess this means that we can’t upgrade the firmware in the future until TR has a workaround of some sort!

For what it’s worth, this is the response I had from support back in March - but I have no idea of the status of any fix, since I’ve just been avoiding the firmware upgrade :slight_smile:

First, Wahoo just released a firmware update to the V5 that added Bluetooth FTMS Support.

FTMS doesn’t Support Standard mode. We were getting around that by using a legacy connection for the KICKR that was built before FTMS even existed.

Our apps prioritize FTMS over any other pairing protocol since they’re industry-standard. Because FTMS was just added to the V5 KICKR, we started pairing it via FTMS (no Standard mode) instead of the Legacy Connection protocol (with Standard mode).

We were able to test this out and it seems that our Beta Android app shows Standard mode, but Electron (Windows) doesn’t.

We’ve written up an issue for this and our engineers are going to take a look. (:

I’ve searched the forums, but still not sure what’s working and what isn’t. I have a KICKR (2018) and use Apple products with TR software (macbook, ipad, occasionally iphone). KICKR firmware is 3.5.2. On iOS (both ipad and iphone) apps, I can see/use Standard mode. But on MacOS (Monterey), I only have ERG/Resistance. Have tried on two different macbooks (same OS tho). Can anyone advise on why this is the case and/or offer a solution? Thanks in advance.

1 Like

I’m not sure about the 2018 Kickr or the MacOS app - best to contact support for exact details.

BUT - it does sound like the same issue I have with the Kickr v5 and the Windows app. In my case as an Android phone user, I see Standard mode in Android but not in Windows. I was told it’s because the phone app keeps a separate bluetooth connection open to get around the issue, but that hasn’t been ported into the Windows app (probably not a priority). From what you’re seeing, it sounds like MacOS might be the same.

For the Kickr v5 it was the Bluetooth FTMS support that triggered it, because TR uses this if available by default and it doesn’t have standard mode (hence the need for another BT connection to bring standard mode back). In the 2018 Kickr firmware I see this:

KICKR '18 Firmware v3.5.1 - 1 June 2021

  • Added: Bluetooth FTMS support

So it does seem to line up that you’d see this problem for 3.5.1 or later. You can downgrade the firmware using the app if you want to try that.

The development team still plans to update the way we connect to devices for desktop in the way we do for mobiles. Until that device migration takes place, KICKR users who update to FTMS won’t have Standard mode on the desktop apps. You’ll need to use a TrainerRoad Mobile app to get Standard mode. Athletes should be able to roll back firmware as well, which you can get help with from support@trainerroad.com, but there are risks with that in terms of bug fixes, for example.

Thanks Ivy, it’s good to know an update is still planned :slight_smile:

1 Like

Thank you. I rolled back the firmware and Standard mode has returned as an option. Can’t yet speak to whether or not that causes any other problems, but it’s a start. Will test it out tomorrow. Thanks for the responses.