Hassles with sensors & Garmin

I’ve been trying to get my sensor setups how I want them to be and am not having much luck getting things to play together nicely.

I’m finishing up the last couple weeks of a strength plan before starting my TrainerRoad base weeks, and the workouts are TrainingPeaks files I run from my Garmin.

I want my indoor ride data files to lack speed/distance data, but the Kickr Snap sends speed & distance data in the power stream and there’s no way to disable this.

I reinstalled my Quarq and connected the Garmin to the it as the power source, but today’s test run didn’t have working erg resistance. I did disable the Kickr power & speed sensor entries, but the “indoor trainer” menu did still list the Kickr as the trainer sensor, presumably through ant-fe.

During the ride, I could feel resistance changing but it wasn’t effective at all, power numbers were drifting around as if outdoors without erg.

I reconnected the Kickr power sensor and erg started working again, but the speed/distance data reappeared so no-go.

Will the Garmin not work to read power data from a power meter and still erg control the Kickr? I’m at a loss as to why it didn’t work as expected.

If all the Garmin is paired to is the Quarq power meter (and specifically not the Kickr), how is the Garmin supposed to control the Kickr?

Point being, you can’t expect the Garmin (or any app running an ERG based workout) to control a trainer that it’s not connected to in the system.

It has no idea the Kickr exists unless you pair the 2 together.


It connects to the Kickr as an “indoor trainer” in the indoor training menu (with a trainer icon), I’ve only disabled the Kickr in the sensors menu as a power or speed sensor.

Hmmm. Afraid I don’t know how to accomplish what you want. Maybe @GPLama can offer more guidance.

As @mcneese.chad mentioned, neither your Garmin nor TR will be able to control ERG resistance without your trainer being paired. Once you get into the TR Base phase, you can pair both the Quarq and KICKR and use PowerMatch to have your power meter control the trainer’s resistance, which you can learn more about here:

Unfortunately, the KICKR will always send speed data along with the power data to either a Garmin or the TR app. The only workaround I can imagine to make your indoor ride files lack speed/distance data would be to pair a speed sensor to the TR app (without a magnet or even a rear wheel) and use the TR pairing hierarchy to ensure we take the 0 values for speed over the speed data reported by the trainer.

1 Like

What I’m trying to do basically is powermatch, just via the Garmin. I don’t understand why pairing the trainer as an indoor trainer sans power/speed sensor streams doesn’t allow for control.

In Zwift, pairing the Kickr under “controllable trainer” as the kickr-FE option and the Quarq as the power reading source accomplishes what I’m going for, and Powermatch is basically the same concept with a name.

All in all, I may just start the TrainerRoad plan a week early to spare myself more frustration troubleshooting it.

I think when you pair the KICKR to your Garmin without the power/speed sensor streams means you’re not pairing it as a “trainer” via ANT+ FE-C, which is the connection protocol required to control your resistance via ERG. If you’re not paired this way, you’re just “listening” to the trainer, but to open up the two-way communication you have to use the FE-C trainer pairing method.

I highly recommend this! Starting early is always a good idea since it will give you more leeway if life gets in the way futher down the line. And, you don’t have to train to start training! If you run into any issues when getting set up, feel free to contact us at support@trainerroad.com.


I’m probably moving on, but just to clarify: I do believe when the trainer is connected as FE-C shown as the status bar icon similar to what is used in Zwift, I’d expect the Garmin to behave like TR and Zwift in this setup and take the power reading from the attached power meter and adjust via the FE-C sensor accordingly. :man_shrugging:

Because “power match” isn’t a feature of FE-C. It is a special feature available from a few companies as far as I know.

I’ve never tried using my Garmin to control the trainer, and a quick Internet search doesn’t turn up anything. Suggest you reach out to Garmin and ask them.