GRX Di2 gear change oddity

I’ve recently had a GRX Di2 groupset fitted by my LBS and done just few rides so far. Yesterday evening I used the lowest gear for the first time (small chainring / largest cog), and after a few seconds in this gear it jumped into the 2nd-largest cog. Did this a few times…

I guessed it was probably rear mech limit screw setting and rode by my LBS on the way out this morning. However, limit screws and indexing all looked fine to him, and then we noticed that the Di2 was self-shifting out of that lowest gear (from small chainring / largest cog -> small chainring / 2nd largest cog) by itself, consistently, several seconds after initially shifting into that bottom gear. It wouldn’t remain in bottom gear. This behaviour seemed to be consistent, occurring without any hands anywhere near the hoods causing accidental button presses.

Clearly looked like a software/config issue, not mechanical, but one which my mechanic pal hadn’t seen before. He left a message with the Shimano tech line while I continued with my ride…

Now back home, I have for the first time plugged in the charger (didn’t need charging, just trying it out) and cycled through the Synchro Shift modes by double-clicking the Junction A button, returning it back to semi-synchronized as it was previously. Now, it all seems to be working correctly: I can change into that lowest gear and it remains there.

Any idea what’s going on? Is there some obvious explanation for what was happening and why it’s now stopped (at least for the time being!)? Thanks!

Was the issue happening in Manual, Or full Synchro shift mode?

Sounds like a firmware issue.

If everything is up to date, I would try a full factory reset on the system and see how that goes. I have GRX Di2 and never have experienced this issue. I run in Semi-Sync shift as I didn’t care for the way it handles the shift to the small chainring. Never did spend any time in full manual mode.

I would check your b-screw adjustment, with the larger gear ratios of GRX it’s pretty important that it is in the right place, neither too close nor too far away from the largest cog. I think your problem could be that the upper pulley is too close to the largest cog, but too far away causes problems as well.

If it is very finnicky and can’t seem to be set correctly I have read of using a link longer chain and then being able to set it but haven’t had to do this myself.

On a side note I also don’t like the way Di2 shifts to the small ring, I’ve tried modifying the shifting patterns but still never sorted it out to my liking. It transitions to the big ring the way I want but I generally shift into the small ring myself and for this reason can’t see me going full syncro, unless I was going to be riding in winter with heavy gloves.

It was in semi-synchro mode at all times; we didn’t try the other modes (we were pressed for time so agreed to circle back after doing some digging). The firmware was all updated on installation a couple of weeks back and is still all current. All very odd!

We guessed that the gear change was being triggered by the rear mech moving, triggered by the software, but we didn’t actually confirm this to be certain (as mentioned, we were rushed and intended to circle back). If the problem returns I’ll be sure to bear in mind what you’ve written.

If this happens again, pay close attention to the RD and listen for any sounds. If it makes a clicking/ticking sound and then shifts back then that means the RD thinks it cannot shift to that gear somehow.
(probably limit screw or B-screw, but could also mean it’s failing in worst-case scenarios :))

1 Like

So that would be a protection mechanism for the rear mech to avoid a situation that might prove damaging to it… Do you know how it actually detects these situations, eg. is it the motor determining that it cannot reach its desired position, or what?

I’m just interested in how this works, if you or anyone else knows the answer. Thanks.

I’m not sure how it does it exactly, but the RD thinks it is physically blocked from moving in that direction.

This also happens when the limit screws need adjusting, but there are other possible causes too, of course.
The clicking can be seen/heard in this video, ~30 seconds in: https://www.youtube.com/watch?v=HIvsY4AtQpI

1 Like

I’ve certainly seen this behaviour with R8000 mech - it would shift into the lowest cog, but wouldn’t stay there under load. Low limit was just that little bit too tight, 1/4 of turn looser was fine. Haven’t seen it on di2, but I guess the same could happen.

It did happen again, so back home I did as you suggested and listened for the ticking sound, which it made.

Despite the RD’s low limit screw already looking OK (ie. not touching it), I’ve just backed it out a further 1/4 turn. This appears to have fixed the issue :+1:, and it’s changing into the lowest gear and remaining there (caveat: I’ve not ridden the bike out of the road yet, so will see…).

Question: does the RD slightly overshift, then move it back fractionally (or is that just the FD?). I’m just wondering why if the low limit screw previously looked OK how it is that unscrewing it a bit more seems to have fixed things (for now!).

1 Like

Good to hear the sound stopped ;-). Yeah, the RDs overshift too, slightly :slight_smile:

1 Like