ERG needing higher cadence

I’m using the Tacx Neo, Garmin Vector 3 pedals, and using TR connected with Bluetooth on Android.

I did a custom workout last night using ERG and ran into 2 issues.

The first being that I had to spin a higher cadence the more watts I needed to push. Here is my workout if it’s any help.

The second being that I had a hard time (not fitness wise) sticking to the prescribed wattage. For example, if TR called for 90w, I was always 10+/- watts. Though, I suspect Zwift does some power smoothing wizardry to even things out.

I’m coming from Zwift, so things may operate a little differently on TR.

I’ve read the documentation and it feels like this isn’t normal behavior. Maybe someone can educate me? :slight_smile:

Thank you.


I wouldn’t mind hearing feedback on this one. I find that over 95 cadence, power is a little more difficult keeping at the goal level. Now down to 90 and lower, easier to keep at goal or higher.

Also, I heard that +/- 10% is about what you want. Seems like the consensuses is that most people don’t use smoothing, I could be wrong.

So, recap for myself. 95 plus cadence, my power is usually neg or equal to goal. 90 cadence, usually keeps on the +/- 10%. Seems like lower goes the opposite, equal to goal or +10%, floats in that range.

Oh, Kickr and Vector 3


Are you using any smoothing of the power display in the TR app?

Your cadence looks a bit erratic at the beginning and middle of some intervals. You need to make sure to hold a steady cadence AND let the trainer adjust resistance to match the target power. Avoid the tendency to chase the power with cadence.

Also, since you are using power meter and smart trainer, PowerMatch. It reads the power from your pedals, and adjusts the trainer resistance to match the power target. PowerMatch can introduce some variations in results because it adds some more timing and math to the process

I’d suggest trying a test without the pedals paired, and use only the trainer for power. Do that and make sure to hold cadence super steady and see what happens.

1 Like

I also have this issue using Vectors and Tacx Vortex.
I raised before and the feedback / advice was that the wi-fi may be causing the issue.
But I feel that if I have lower cadence it can keep up and keep the resistance that I need. It is when I speed up to 90-100 that the trainer really struggles to keep up the power - the result being c.5-10 watts under target on a 2-3 min interval.
I’m thinking of upgrading my trainer to direct drive - but would be gutted if I did this and had the same issue.


what gear are you using for your trainer?
no it doesn’t matter, but it can make a big difference if the flywheel is spinning too quickly and changes in power occur.

I do find it hard to hit the “floor” in TR when it calls for like 50w, for some reason any pressure on the pedals just creates 90w or so. Bu that’s fine because it is basically zero effort. What I am more concerned with is the interval power so as long as that is within 2% i am usually OK.


I believe that was the default setting for me and I didn’t touch it. I’ll check it next time I do a workout.

This is a great tip. Guess I was thinking that TR would eventually even it out for me.

I’ll double check that TR is using PowerMatch.

Will do.

Thank you. :slight_smile:

1 Like

I’m using the small ring up front and about half way down my 11-speed cassette.

Will try being in the big ring up front next time.

1 Like

for the issues that you were describing small ring should be fine. IF you are in the big ring you CAN end up with a flywheel spinning too quickly and this can make it difficult for it to adjust and overcome its own inertia. Doesn’t sound like that was the problem.

It sounds like you were simply “chasing” the target as @mcneese.chad described. In that case, don’t focus on what the ACTUAL power is at, just focus on maintaining a steady cadence. Let the actual power bounce around but once the interval/workout is done review how far off you were for average power vs. target power for that interval. If it’s still way out and you maintained a steady cadence with no variation, then report back as you may have a different set of errors going on.

Here’s something odd I spotted working through Geiger earlier this week. Those first two intervals I was on the little ring and half way down the cassette. I was surprised at how much my heart was working. The last interval I moved to the big ring and it felt so much easier. (You can see where I took a breather to get a new bottle and wipe down, but even so, my HR didn’t climb back to the heady heights of the first two)

Gearing in ERG matters.

1 Like

Useful links, thanks. I tend to do most in the big ring, dropping onto the little one during recovery so that I can hit the lows at the appropriate cadence.

1 Like

Yeah, that’s about working within a trainer floor and ceiling of resistance levels. Some require shifting to get up or down, depending on the resistance requirements.

So here is another example where my trainer just couldn’t keep the power needed. During the first set of intervals I kept even cadence and focused on the recommended cadence for the workout (100rpm) or just below to allow the software or trainer to crank up the resistance to meet power. this just did not happen, so in the end to meet power I had to use gears, which just seems wring.

I actually switched to Resistance mode for the last two sets.

Hi - me again!!
Just as an FYI I purchased the Tacx Neo on BF - a steal at £850?!
The results have been a transformation. There are no issues that I reported in this thread and when I reduce cadence the resistance increases really quickly and when I spin faster the reverse happens just as quickly.
I now feel so much more benefit from the workouts and can actually make use of the ERG function and workouts with microbursts without being frustrated.
Whilst this may have been a firmware issue on my Vortex the change in trainer has been a game changer.

1 Like

Sadly, a common conclusion. “Budget” trainers may be easier on the wallet, but that lower prices doesn’t come without it’s own set of issues.

Glad you are super happy with the upgrade. I still haven’t had the pleasure of trying a Neo, but hope to some day.

Pretty late, but I figured out the issue was caused by me.

Using the tips given here, I was able to steadily control my cadence to the point where I can pretty much ignore the TR display for the most part and ride purely based on feel.

Thank for all the tips. :slight_smile:

1 Like

Glad that you got it all sorted and working better now.

Thanks for reporting back too. Happy training :smiley:

1 Like