ERG Mode working very badly in Tacx Neo (T2800)

Hello TR Community

I used to have a TacX Flux S that broke recently. I bought a used Tacx Neo (T2800) as a replacement.
Now I really struggle with ERG mode which is not working properly. I am aware of ERG mode and how it is supposed to work, with the Flux it has always worked like a charm.

Example:
FTP Test with Flux

FTP Test with Neo

The jumps are much worse - I think my cadence is steady enough. I tried using different apps, Bluetooth and ANT+ and different devices - but the problem still occurs. I always just connect a HRM and the other sensors are all from the trainer.

Do you have any additional tip that I could use to make it work?

Kind regards and thank you already a lot.
T

Use lower gear. Lower ring in the front, middle of cassette in the back. (If not already considered.) Otherwise this doesn’t look typical for Neo and I’d suggest contacting TR support to have a look at the workout and what instructions were sent to trainer (and then maybe also Garmin support).

Hmm, that doesn’t look good.

IIRC, somebody else here had similar issues and it turned out to be paired to TR using both BT and ANT+.

It might be worth checking for you.

Looks just like it!

Thank you for this hint – it occurrd with or without ANT+ dongle attached though. I once connected with TR and the TacX App once with each protocol. So I guess this can not be it.

I will try this tomorrow, not very optimistically… https://tacxfaqx.com/knowledge-base/resistance-factory-reset/