Erg mode is dead on Snap

Since today, erg mode on my Kickr Snap is dead, it simply stopped working while resistance mode and standard mode are just working fine. Last sunday, erg mode was still doing its job, but now power output stays the same, no matter what prescribed wattage.

I pulled the plug for a minute, forgot the device and reenabled, tried riding with different master device (Ipad instead of Iphone), but it didn’t do the trick.

I also tried calibrating the thing, both on Trainnerroad as on Wahoo Fitness, but it won’t let me: speed goes up to 24 km/h and then goes back to zero saying the calibration has failed.

Am I missing something here, or is it broken?

Just contacted Wahoo Support, who advised me to do a factory spindown, but apparently I can not perform a factory spindown. When following instructions, I get a speed reading the first five seconds of the spindown, then everything drops to zero. Even when selecting a new workout, the same happens: I get power and speed reading for the first few seconds, then everything drops to zero and can’t get a reading at all, it’s like i’m not on the bike.

If any could help, that would be nice. I would like to still do a ride this evening :slight_smile:

Sounds like HW failure. I’d relay that to Wahoo.

Try cleaning the optical sensor. There should also be some tape on the flywheel that the optical sensor reads. Clean that too, if you can. If that fails, then you’d really need Wahoo support. The sensors have been (at least on the KICKR v1) replaceable, and support would send new ones as needed for purchase.

2 Likes

actually cleaning the magnetic strip helped! …until halfway through my workout, when I pressed pause for a brief while and started again, and the trouble started over and erg mode was gone. I switched to resistance mode, but after a few minutes, this disappeared too.

Wahoo said that this is indeed a hardware problem and is pushing me towards replacement of the rear unit for 225 dollar.

Ok, 2nd day of testing and I found out that, during a spindown, I can reach a speed of max 26 km/h in the small gearing, while spinning faster or putting it in the big ring results in lower speeds or even 0 km/h.

Alright think with me: this clearly has something to do with the speed of the rotation of the flywheel i.e. the optical sensor which isn’t working properly, right?

Do you have extra bright light or anything “different” in use?

Would be interesting to try a very low light situation, since I know that sometimes the Kickr’s can have issues with bright or direct light near the sensor.

I cleansed the optical sensor and I think that may have solved the problem. Will test again tomorrow. If it’s the case, @iamholland just saved me 800 euro, because I was really close to buying a Kickr Core already :slight_smile: so thanks man!

2 Likes