Di2 issue keeps falling asleep

So my Di2 has been a little odd. It’s happened twice now and first time it just somehow went away. Both times it happened after charging. I have to press the left hand lever for about 5 seconds before I ride to wake it up otherwise it’s totally dead. After that it works o.k. but every time I change on the cassette I have to keep the shift lever pressed a little longer to almost wake it up again before changing, once it’s woken up it changes as normal but only for about 5 seconds then I have to wake it up again. After leaving it for a few hours I have to then wake it up with holding the left lever in the shift position for 5 seconds or so again… Very strange…

1 Like

could be a firmware issue. Take it to a shop that has di2 diagnostic tools and they’ll sort it out for you

1 Like

mine has just started doing this too - the first press after 15 seconds or so doesn’t do anything, just seems to wake up the system for the second press to change gear

did you have any luck in fixing it?


check the cables and make sure they’re not frayed. if they look good, bring it to a shop to do some diagnostics on it. Could try updating the firmware yourself if you’re comfortable with it, that might solve some problems.

1 Like

Hi, I took it into the shop and they changed the battery which fixed it. Apparently there was a bad batch of batteries a couple of years ago that did this sort of thing.

1 Like

I thought I had a bad battery cause it stopped working out of the blue one day. I ran diagnostics (yes I bought one cause I’m crazy like that) and resetting firmware / reupdating etc fixed it.

Glad you got it sorted though!


thanks guys!

i’d heard about that frayed wire thing before - so i straightened up some pretty sharp looking corners in my cabling where it had been taped to the brake hoses. seems to have sorted it out (for now) but i’ll also get a firmware update and diagnostic done, once i get hold of a windows pc (can’t believe no etube for mac!)