Connection issue

I tried to use Trainerroad on my Mac yesterday but could log in, the error I got was this:

I did contact support and they’re looking at it, has anyone else experienced this? This morning I tried to run Trainerroad on another mac computer and it worked fine.

Trainerroad version: 2018.52.0.88646 (2018.52.0.88646)

Running MacOS Mojave on both computers, no firewall or anything. Tried different networks but same issue.

Hey there! I looked into this issue and chatted with Ming about it - we think it might be a problem specific to your Mac. If your phone and another Mac can log in, that means it’s not a problem with your router or provider. Especially if you tried using a different network.

What’s different about your Mac that’s experiencing the issue? Something must have changed the other day when you could no longer log in. I’m not sure what is going on but I’m happy to help troubleshoot.

For posterity’s sake, can you confirm that you don’t have an active firewall under this menu in your computer’s settings?


Thanks for getting back to me!

Yes I’ve checked the firewall and it’s off.

It seems like it works on all ot her Mac computers I’ve tried it on, so it must be something specific to mine. However it’s a bit strange that all other apps on that computer can access internet (i.e. Spotify, Skype etc) but Trainerroad seems blocked for some reason.

I also tried reinstalling the MacOS but that didn’t help either I’m afraid. Also tried with the beta version of Trainerroad, same issue.

Thanks for verifying that! As I said, this is super strange and we all seem to be in agreement that it must be something with your computer.
Are you able to access on the web browser of that computer?
Is there an Apple store nearby that you could take the computer to? They may be able to examine this and investigate a little further than we can.

Yes I can access on the computer.

I understand if there’s not much you can do in this case, don’t have an Apple Store nearby but I’ll try to reset the computer or something.

Thanks for all your help! I’ll let you know if I manage to fix it :slight_smile:

Sounds good, sorry we weren’t much help!!

Hi @uberweiss,

I’m having the same problem and really struggling to get to the bottom of it. Did you ever find a solution?


Hi @James_Graham, have you reached out to us at yet? We might be able to help troubleshoot this as long as it isn’t the exact same weird issue @uberweiss was experiencing. :confused:

Hi @James_Graham!

I did not, unfortunately, so I’m using the phone instead.

Please let me know if you manage to solve it :slight_smile:

Thanks for letting me know @uberweiss. I’ve resorted to the same but will let you know if I come across a solution.

@uberweiss, with help from support we eventually figured out it was due to my mac’s hostname somehow having a linebreak character at the end of it. The fix was to reset my computers hostname.


  • open the Terminal app
  • type: hostname
  • it’ll tell you what your current hostname is. Copy this, ensuring only the characters are selected, nothing after.
  • type: sudo scutil --set HostName YourHostNameHere where YourHostNameHere is what you copied in the previous step

Not sure if that’ll help but you never know!

@James_Graham thanks for getting back to me!

I tried changing the hostname but didn’t help me I’m afraid. Should I have the ] sign at the end of the hostname?

No sorry the square bracket at the end was a typo, I’ve edited it out now. Sorry to hear that didn’t help, must be a different underlying cause.