Chromebooks work on TrainerRoad?

Update, chromebook has been working fine for me. Using bluetooth built in has better and smoother power output than a dongle.

hopefully on Android side of thing this just get better with new features.

I’m assuming it’s a chromebook which is android app compatible? Did you have to sideload TR?

The display is the same as I get on my android “TV” box. Despite being apparently unsupported, it was visible for me in the Play Store.

No I didn’t have to side load I got straight from the play store.

I finally got TrainerRoad up on my chrome book. The blue tooth is connected, but it wont pick up my speed & cadence sensors. Did you have any problem with that?

I use my Power Meter. Everything works fine for me even in power match for my H3. Try turning on/off the blue tooth, maybe restart the app. Sometimes I have to do that to get everything connected.

1 Like

I’ve been using a Chromebook to run TR since January. Ran virtual power using a Bontrager Speed and Cadence sensor with a Wahoo TickrX HR monitor.

Only issue I have is that it usually does not detect the BT devices when the app opens up. Like @aaronwashere said, I usually have to either toggle BT off/on and/or forget and repair the devices. Once they connect everything runs perfect. There is a lag with virtual power and bluetooth though. It would take 5-10 seconds for my power to report accurately when cranking out VO2 max workouts.

I picked up a Wahoo Kickr yesterday and did my first ride with it. Also had the HR and Cadence sensor paired. This was my first time pairing three devices. The Kickr paired faster than the HR monitor and it took longest to get the Cadence sensor paired but everything ran perfect once paired.

1 Like

Ok today was the first time I truly had a major issue with using my Chromebook to run TR.

Went down to the paincave like I normally do and started up TR. It started up but never went to the workout screen. This has been happening lately so I just restarted the Chromebook. But when it restarted and I opened up TR it didn’t detect my BT devices(wahoo kickr and tickrx). I tried toggling BT on and off and even did another Chromebook restart and nothing. TR and my Chromebook were not detecting my BT devices. I was pressed on time so I just used my android phone to do my workout(ruled out the app as an issue). My phone detected and paired with my kickr and tickrx so I knew they weren’t the problem.

Came home after work and messed with my Chromebook. TR still was not detecting my devices so I deleted and reinstalled the TR app and still nothing. I finally did a Powerwash(full reset) and once I installed the TR app it started detecting and paired with my tickrx.

I’m not sure what happened but it seems to be working now. I’ll know for sure tomorrow morning when I have do my next workout.

Lately I haven’t been able to get my devices detected too. You think it’s because of the new beta?

Ive been using my pixel slate chrome tablet on TR since May 2020 without issue. I went to connect for a workout tonight, and was unable to get my device to connect despite repeated attempts of turning on/off bluetooth and reinstalling TR.

I also attempted to connect via my new phone (pixel 4a 5g), it still failed despite turning the light on my saris h3 flashing blue (on my pixel slate attempts it would remain flashing green), neither would connect to the normal solid blue.

Interesting enough, I loaded up zwift on my phone and it connected right away.

I’ll back up my pixel slate and try it again. Does anyone have any other suggestions?

Tried again this morning and it was a no go with the Chromebook. I didn’t have time to mess with it so I just used my phone again(Pixel 4 XL) with no issues. I’m not using the beta app and the TR app I’ve been using is the most recent one in the Google Play store which was last updated January 2020.

While I was eating breakfast, I was just browsing the internet and checking emails and noticed that the Chromebook required an update. I updated it before I did my workout. I have a feeling that the latest Chromebook update broke the ability for Android apps to connect with BT devices but I haven’t tested that theory yet.

BT works fine on the Chromebook. I tested it by pairing a set of headphones and listening a youtube video in the Chrome browser.

So far I have ruled out the TR app and the BT functionality on my chromebook. I’m going try the Powerwash again but note which build it restarts at and compare it to my current build.

I’m a Slate/4XL user, and I haven’t had any luck with the slate connecting via Bluetooth either. I’ve defaulted to using an end-of-life Nexus 6 (Shamu) mounted in my Garmin mount, and it has been flawless. I can only guess that the more current Bluetooth protocol on the Slate is the issue, as the older Nexus 6 hasn’t been updated, but still provides a stable connection. ANT+ has been unreliable for me on the Nexus 6, even though the dongle was only 3 feet from the transmitter. Looking forward to hearing any updates.

Another update.

I downloaded the Wahoo fitness app to see if that would detect my Tickrx and nothing. Did a powerwash/reset and after TR was finished installing I tried to connect my Tickrx. It worked just like last time I did a powerwash. Same thing with the Wahoo app. Both apps detected my Tickrx and paired.

I checked the Chrome OS build and it was the same before and after the Powerwash. Both builds were: Version 87.0.4280.142 (Official Build) (64-bit)

I then restarted my chromebook to see what would happen. The TR app would not detect my Tickrx. I toggled BT on and off and still nothing. I then tried the Wahoo app and at first it would not detect it but if I clicked on it in my connected devices it would then connect.

I have no clue what is going on. I’ve hit my limit for tech support. I still think it might have something to do with the most recent Chrome OS build. I’ve had a lot of issues recently with TR and my BT devices on my chromebook.