Can't Connect Favero Assioma Duo

Hello, I just purchased the Favero Assioma Duo but for the life of me I can’t get Strava or Wahoo to show any power. It’s just 0.0 for days. I’m pretty sure I followed the directions correctly but can’t figure out what step I’m missing. I only have an iphone xr - no garmin computer or anything like that. If anyone has any suggestions, I am all ears. Thank you!!

So you have paired them with the assioma app? Registered them, done zero offset and done few minutes of steady cycling to get them up and running?

For me the problem was that I was not doing long enough first time cycling to get them “calibrated and running”.

Thanks Niko,
I’ve done all the initial set up (assioma app registering/pairing, zero offset) and I’ve just gone around the block a couple of times while messing around with them. When you’re doing that initial cycling, should I have the assioma app running? The last time I tried it I had the wahoo app open and I was trying to calibrate them that way. (Wahoo has already connected with them but nothing else).
I should add I’ve been reading as many forums as possible but didn’t see my exact scenario.
Thanks in advance for any help!

For what it’s worth, I rode 7 miles tonight and both Strava and Wahoo just had 0.0 showing the whole time, BUT afterwards Strava gave me an average power for the workout. Soooooo I guess that’s a step in the right direction?

You may need to have the wahoo app open and connected to the head unit the first time… If you try to have it connected to both your phone and the wahoo, it may be a problem trying to connect with Bluetooth and ANT. Go into your phone and forget the device and connect to your wahoo again and see if that helps.

Turn off the other apps connected to the pedals on all your devices
. Sometimes they are running in the background on an iPad or iPhone etc. If you have have Apple, double click the home button and swipe each page up.

If using trainer road, only this app should be running. Close everything else, everywhere.
If going outside, shut down everything so just your head unit is connected

Thank you. I actually don’t have a head unit. I (foolishly?) assumed just having a iphone would do the trick. I guess I’ve gone this far down the rabbit hole, what’s a few more dollars…

Thanks Chancie - that’s a good idea, swiping up to get an official fresh start. If I had a head unit, it sounds like I’d be up and running at this point. Thank you!

Oh, yeah, I’ve never tried it with just Strava app or Wahoo app. I’d think if one of those did support power, you’d only be able to run one at a time. Regardless, you’ll have to connect to your ohone’s bluetooth for that, but, not ideal.

@bmcdonald, beside initial setup in assioma app, did you also go to setup page on cycling apps (Strava/Wahoo)? The External sensor connection via BLE (for Ant+, need extra dongle) should be enable and paired.

1 Like