Calibration doesn't work with Zwift Hub (TR PC)

Hi there,

I encounter the following issue: when I want to do a spin down calibration on my Zwift Hub, the TR desktop client tells me to “Speed up until you reach 0.0 KPH”. Well, I am pretty successful in doing so but obviously that won’t do the trick.

So then I tried to pedal to a normal calibration speed. The speed is being read and the app even tells me to stop pedaling but the calibration never succeeds.

I use a Zwift Hub smart trainer so maybe it doesn’t work because you need some device-specific update first - but maybe not and somebody around here can point me in the direction of a fix?

Thanks for any help!

Hey! Looking into this now for you. :+1:


Does it work when you are doing the workouts? Also I don’t know if this changes things but could you just do the calibration using zwift’s app then do the workout?

We don’t have a Hub in-house to test right now, but we can see if we can get our hands on one to make sure we’re fully compatible and can better work out future troubleshooting steps.

In the meantime, there a couple things you can try:

  • Try spinning up to >39KPH before letting the trainer “spin down”
  • Try the TrainerRoad mobile app for the calibration instead of your standard desktop method you’re currently using.
  • Calibrate on a head unit (Garmin or Wahoo). The calibration is stored on the device itself and will carry over into TrainerRoad.

Let me know if any of these help!

1 Like

Change from erg to resistance mode

Thanks for looking into this, @IvyAudrain! I’ll try your suggestions once I’m back home :slight_smile:

Just one follow-up question: when you talk about calibration data being stored on the device, are you talking about the head unit or the smart trainer? I assume the latter. If so, does the same apply when calibrating with another Software product instead of a head unit, i.e. could I try what @tfilteau suggests?

1 Like

Yup, the zero offset / calibration is always stored in the actual power device itself, the trainer or power meter in use.

1 Like

Any update on this ?

Hey! We do not have an in-house zwift hub trainer for testing currently.

There is an update on calibration insight though, I did see via DC Rainmaker that:
“In my testing, as well as what Zwift themselves say – they recommend doing a spin-down calibration at about the 10-minute marker.”

Are you also experiencing calibration issues? Let me know and we can try to help!

I’m relatively new to the platform but have also been unable to calibrate using a Zwift Hub trainer. Behavior is similar to the original poster, asking me to spindown from 0.0. I just wanted to chime in that this still appears to be an issue with the desktop application for Zwift Hub users.

I have a zwift hub. Using the TR app on my phone i can calibrate it easily enough. Have you installed the latest hub update?

Hi alpineclimber. Thanks for your recommendation. My comment was in reference to the desktop application. I haven’t attempted to calibrate using the mobile application and I don’t typically have a phone nearby when using TrainerRoad.

I will try to calibrate using the phone application as you’ve recommended and will report back, but TrainerRoad recommends calibration before every ride. I just wanted to say that I was still experiencing the issue that the original poster spoke of. My Zwift Hub is up-to-date in regards to firmware.

this is the same issue I have been having on a Tacx vortex so don’t think its device specific

As OP just a bit more detail on what currently works and doesn’t work for me - all this refers to the TR Desktop application:

I connected my Hub via both Bluetooth and Ant+

When I click on calibrate on the Bluetooth device, it tells me to spin up to 0.0 km/h. However, when I spin to 39 km/h I end up getting a “calibration successful” message. I do, however, get it before the wheel stops completely which makes me wonder whether or not this can be accurate.

When I click on calibrate on the Ant+ device, it tells me to spin it up to 32 km/h but even when I do the calibration never appears to be complete - I simply don’t get any feedback from the TR app.

Anyone email TR support directly about this issue?

Not me. For me, it’s okay as is because eventually the calibration works (hopefully accurately), even though the UX to get there is broken.

Thanks for that extra info @ThomasE :+1: . I spoke to the team about this and we are going to check if it’s possible to get a Zwift Hub in-house to test this out. We will keep you posted about this.

At the moment, I think it would be best to calibrate the trainer in the mobile app, seeing as we are seeing athletes able to do this successfully.

@Alansd1980, i’m going to look into your issue separately, and circle back.


Hey @Alansd1980, I see that you have both a Mac device and iOS device. Do you have the calibration issue on both devices?

Just to clarify, when you calibrate the trainer in the TrainerRoad app, are you seeing the screen that @ThomasE shared (see below)?

Are you able to calibrate the trainer in the Tacx Utility app? The calibration is internal to the trainer so if you calibrate it on the Tacx Utility app, it will carry over to TrainerRoad.

Thanks in advance if you can answer those questions; that will help point me in the right direction :smiley:.


I just tried connecting it to the Mac and calibrated which worked, I then connected to he iOS device and it worked. Thanks for the prompt!

1 Like

Hey there,

We’ve been doing some digging on this and may have found a potential fix!

Open the TR app and go to Settings. Under “General,” you’ll see a setting for “Wheel Circumference.” Please make sure this value is not set to 0. For reference, 2096 is typically the default value.

Go ahead and check that out and let us know if it helps!