Wahoo Elemnt Bolt crank length issue

I have connected my new Rotor INpower powermeter to my new Wahoo Elemnt Bolt device, but when I try to set the crank lenght the following thing happens: I change the value on my Bolt device to 170mm, then press calibrate and after calibrating the crank lenght is automatically set back to 172,5mm. This happens all the time and it seems like the 170mm value won?t be saved. I also tried to set this in the Wahoo app, but there it seems like it can’t be saved either since it switches back as well… How can this be solved? Thank you in advance! Kind regards, Nathalie

I don’t know but, just interested for future ref if I ever go to pedal or arm based PM…Does the Rotor INpower have an app where you can change the arm length? If so, try that first then change on the Wahoo app perhaps? IIRC 172.5 to 170 is about 1.5% so keep riding with relative confidence. Report back if you figure it out. For me Wahoo customer service has been hard to get help…good luck!

There is a Rotor app to connect the power meter, but you can’t adjust the crank length there… Do you mean the power output would also just give a difference from 1.5%? The pedaling circle will be smaller and with a higher power the difference will be bigger I think? I’ll try to connect Rotor itself, cause the same issue also occurs with my Garmin Edge… Thanks!

EDIT - see below

Right, remembered how to do it (assuming its the same for the Rotor):

Make sure the head unit is turned on and paired with both your phone and unit before you start.

Step 1 - open the Wahoo app and find the sensor:

Step 2 - configure crank length

Step 3 - default will be 172.5, change it to what you need

Step 4 - you should see that change reflected in the head unit settings (on the power unit page)

THEN you can calibrate (though Assiomas have a separate app for that, suspect Rotor may too)

If I understood correctly, the accuracy gets worse by approximately 1% per crank length change if not set correctly.

Thank you for your answer! So do I have to stay on the page or not stay there on the Bolt when calibrating through the Rotor app? Should I close the page in the Wahoo app before switching to the other app?

It shouldn’t make a difference with the head unit as Wahoo should have ‘set’ the sensor as the right length by that point. I’d try just opening the Rotor app as I don’t recall deliberately closing the Wahoo app.

It didn’t work out unfortunately… I contacted Wahoo support and they told me it’s a software bug. So they will prepare and update so solve the issue. So that’s good news. :slight_smile: Thanks you for your answers!

1 Like

From what I heard from support calibrating the Rotor is enough and the crank length doesn’t affect the power… It seems to be a bug in Wahoo which they will solve :slight_smile: Thanks again!


Sorry to dig up an old thread, do you mean that setting the correct crank length on the Rotor app is enough to solve the issue or that calibrating on the Wahoo was enough (without doing anything on the Rotor app) ? Running into the same issue.

Sent my Wahoo head unit back 2 years ago because of this very issue. Seems they still haven’t fixed it which is really sad.

Come on Wahoo, fix CNK LTH.

I sent in a support ticket with both Rotor and Wahoo, I will update this thread when I find out more. After a lot of research it seems like all the Bolt is doing is initiating the calibration process but the Bolt settings do NOT affect any part of the calibration. Rotor’s calibration process does not require any adjustments for crank length which leads to believe that it is irrelevant to make adjustments through either the Wahoo app or the Bolt itself, this supports what Nathalie wrote above. Either way this is confusing and hopefully I haven’t had incorrect power data for two years :upside_down_face:

" Note: while the ELEMNT/BOLT/ROAM sends and receives calibration commands and data to and from power meters, it has no role in the calibration process itself."

4.1.1. Activate your power meter (follow instructions in section
3.1. of the user manual) and complete the following calibration
process in less than two minutes.
4.1.2. With the bike upright and level with the ground, place the
left crank in the 6 o’clock position as shown in the picture. Make
sure to complete the calibration process with the pedals already
installed; do not place any weight on them until the process has
4.1.3. First calibration: follow the specific instructions for your
ANT+™ device to send the “CALIBRATION” signal. You can
usually find the “CALIBRATION” button in the menu:
Settings\Bike settings\Bike profiles\”Your profile”\ANT+Power.
4.1.4. The device must show a value of 1000 or a message of
successfull calibration. Turn the cranks counterclockwise at least
two turns at a moderate speed, returning again to a vertical
position with the left pedal down, making sure that the crank is
as perpendicular as possible to the ground for accurate angle
4.1.5. Second calibration: press again the “CALIBRATION” button.
The device then returns a calibration value between +/- 200.
There are some monitors in which a successfull calibration
message will be shown. The second calibration has finished and
the power meter is ready to use”

AFAIK the strain or shear gauges of Rotor’s InPower power meter sit in the spindle, not the crank arm. So the measurement should not be affected by crank length.

1 Like

My particular issues was the the Bolt (Paired with Favero Assoma pedals on 155mm cranks) was that even if I properly set the crank length on the pedals in the Favero app, the Bolt would overwrite that data. And since they have a fixed dropdown list of crank lengths that ends at 165mm, my power would always be off. Garmin just lets you input a number instead of relying on a fixed hard-coded drop down.

I hear this!!! The really frustrating thing though was that I spent a couple weeks thinking I was amazing even on the trainer because when I went outside, the Bolt reset my crank length in the Assoma to 165. Then I take my bike inside and do a sweet spot workout, thinking I’m at say 4W/kg, when in reality I was only at 3.7W/kg

1 Like

I believe this is accurate and why there is no crank arm length adjustment from Rotor’s app. That being said I’m testing out the Rotor pm vs my Kickr to see how close they are. Not really sure what the best method to use to compare the two data sets other than average power or NP. Did two small 10 minutes tests this morning, one set of NP was identical and the other the Rotor was over by ~8w. Will be testing again today if time allows or later this week with a longer session.

Sharing your frustration Michael ! I did a deep dive into the FIT files from my previous FTP test on the trainer (using the Kickr pm) and my FTP test from yesterday where I used the Rotor pm (again on the trainer). From what I can tell if you are on Zwift the power source defaults to Zwift, not Wahoo or Rotor which is making doing past comparisons a nightmare.

Keep in mind that your Rotor power meter is a one-sided power meter. If your left-right balance is 52:48 instead of 50:50, that would be a 6 W at 300 W indicated power. So that alone could account for the difference. I’d check if the two power meters are consistent.

Overall, Rotor’s power meter have a relatively good reputation according to the usual suspects. Not quite as good as Quarq’s DZero and the Assioma pedals, but a very solid choice. Plus, Rotor’s cranks are amazing.

1 Like

I came to this conclusion as well and emailed a contact at Rotor I have to see if this seemed accurate. His reply was that a 5% variance between a trainer’s power reading and a dedicated on-bike power meter was due to drivetrain loss and totally normal so I think I’m okay with the delta now.

1 Like