Stages StagesBike SB20 (Smart Bike)

I have it set up just how you’ve listed - connect the Stages Bike as a controllable trainer, and do not connect either of the crank arm power meters.

I have run mine a bunch in resistance mode for TR workouts, but I always need a secondary app for shifting - there may be a way to do it only in TR but I haven’t figured that out yet. I am usually dual running Zwift whether in erg mode or not, and to use TR in resistance mode I:

  • Load up the workout in TR on my iPad (Bluetooth), connect to the bike and my HRM, and then switch the SB20 to resistance mode in TR.
  • Start Zwift on my PC (ANT+), and make sure to set the SB20 as a controllable trainer.
  • Using this setup I can change gears with the bike’s shifter buttons, and TR records the higher / lower resistance and power.

When I am using TR in erg mode I definitely want Zwift to have controllable as OFF, otherwise they will fight over the power level - this is only the setting for non-erg training.

There may also be ways to do this with the SB20 app and not need Zwift, but given that I’m usually running it anyways this is the setup I’ve configured.

1 Like

So I did my first workout today in resistance mode + DreamDrive, and I really, really liked it. The road feel is much better than in ERG mode. Plus the shifting is so unnaturally smooth.

The only thing that was weird was that I had to set the SB20 resistance at 40% to have any recovery interval. Does anyone else have the SB20 resistance set at less than 100%? If so, what do you have it set at?

2 Likes

Day 3 of trying to resolve an issue with SB20

I have been following the trouble shooting guide and have updated firmware, paired and unpaired the bike, checked crank ID etc…when I use the Power App both cranks connect, but when I click “link”/“verify” it fails to pair. The trouble shooting guide says to make sure PCB orientation is 4 and 5. When I click on tools PCB orientation is not listed. When I try Trainer rd/Zwift it connects and pairs using ant, but shows 0 power when turning the cranks. Any help appreciated…
I did reach out to TR team at an earlier stage in the trouble shooting and they were super helpful, but it does seem to be a Stages problem, so wondered if anyone had experience of this.

Having issues with mine too. he only way I can get both power meters o show on the Power app is to unplug the bike. The right power meter seems fine. This all started after the last firmware update. There is a new 7.1.2 release, but can only get the right side to update and can only do it in the Link app. Took over a week and several phone messages before I got any response from Stages. Still working for a solution.

I feel your pain.
I got the PCB orientation solved with the help from someone on the FB Stages bike owners page.
Struggling to update firmware via the link app, but able to update to 1.7.2 via power app (why do they have 2 separate apps anyway?)
my son helped my sort out some of the problems in iphone, but we focused on the power app as the link app seems glitchy.
we found that in the power app you need to do a hard close between connecting each crank and before connecting them both.
My left crank now has a serial number of 0 which (I think) why I app not getting power displayed in TR / Zwift.
Apparently i have to wait 4-6 days to get a response from stages.

you could try the FB Stages owners page. some helpful people on there.

Have you made any progress?
Apparently, you can do a hard reset by flipping the battery upside down for a few seconds and then putting it in the right way again

I’m out of town for work this week, so I won’t get back to it till the weekend.

1 Like

The serial number on my left crank went back to 0 this morning. I managed to get it to connect and do a TR session though. Saddleback are sending me a new crank, as without being able to hold a firmware update, it’s going to have further problems.
If you’re uk Saddle Back is definitely the b at point of contact.

Looks like I got it ironed out. Stages told me that with the bike plugged in only one power meter will show up in the power app. So I put the battery back in the meter I thought was faulty and unplugged the bike. Both power meters showed up and showed that the firmware was up to date. All worked fine the other day. Seems odd to me, but all worked fine.

That seems bizarre, but glad it’s working for you. I unplug mine between sessions and plug it in when I’m using it.
With my new crank -power metre fitted everything has been working well. However, I did a zero reset in the stages link app this morning and the power seems to be about 20 watts harder than before. I’m going to have a play around with it in my recovery week and compare it again with the power after zero rest with the power app.
Do you use the link app to do zero reset? Do you add calibration in TR?

I used to only use he Link app, bu Stages said to use the power app for the zero reset and for firmware update. he Link app seems o have caused some of my issue, no sure how, but it did. Mine does not calibrate via TR. I had ask TR tech support about that and they told me that the Stages Bike is not set up at this time to calibrate through TR. They told me just to do the zero reset through he Stages app,

1 Like