Past ride Upload problems

Hi there.
For some reason, my ride from yesterday morning is not being uploaded to my calendar, nor it’s showing on my past rides.
I have tried uploading it manually, disconnecting and reconnecting Strava and Training peaks…
Am I missing something?
anybody else has had this issue?

Same issue here. If you read the post about TR with Zwift. It uploads eventually but hours later if it does. I’ve had some success resync my TR but that’s not how it’s supposed to work. I have an open ticket with TR support.

I’ve got this issue too - also raised with support by no response yet.

Strangely I can’t upload it manually (exported from Strava ad Garmin). Which means it must exist (and not allowing a duplicate) but it’s just not showing up. Nothing at all unusual about ride - it’s the first one that’s not sync’ed.

Hey, all. Sorry I’m just now seeing this thread!

We had an issue in which completed rides were delayed in their upload process due to an unexpected result of some maintenance we were doing on the site. This should be fixed now.

However, this isn’t to say your un-uploaded rides aren’t attributed to something else.

@caetano, @Dlessard75, and @Gidon_Reid, I’m going to have a Support agent reach out to each of you, individually, to get things sorted out this morning. It’s 6:37 in the morning here in Reno right now, so no Agents are working just yet. BUT, I’ll make sure my 7a.m. crew prioritizes this for you all!

Keep an eye out for a response, eh?

Thanks, and I’m sorry about the hassle!

1 Like

To me, the same training of Trainerroad in Trainingpeaks is loaded twice!

This is a known issue that’s affected a handful of riders. :confused:

Luckily, our Development Team is aware of this issue, and they’ve been investigating since yesterday. We’re going to try our best to have this fixed as soon as possible!

Hi Alex,

I am not sure it is fixed. If you take a look at my profile I completed Geiger +2 last night (ouch!) concurrently with Zwift. I ended the TR workout first…took a shower…still didn’t show up…then ended Zwift. Zwift is showing but not the TR.

Hmm, your situation may be attributed to something other than the more widespread problem we had the other day that’s since been fixed.

I’ve pulled your ticked you have open with Support, and I’ll make sure it gets prioritized this morning.

We’ll continue our communication with you from there since it’s a little easier and more organized to troubleshoot more unique issues through our tech support channels than here. :slight_smile:

(That being said, at a quick glance, I’m guessing this may have to do with our time-stamp logic for workout uploads. We’ll dig deeper and get back to you soon though!)

Thanks Alex. I’ll keep an eye out for support!

1 Like

I have the same issue, neither it is syncing with Strava (tried couple of times disconnect and connect), nor I can upload the *.tcx file. After the import it is saying “Upload complete. Refresh to update.”, but nothing is there after the refresh.

Thanks for letting me know, @Paukman. I’ll have a Support Agent reach out to you to help.

For anyone else experiencing a similar problem, please email our Support Team at


1 Like

Same problem here, where my TR rides not showing up in Career or Past Rides view and also not being credited in the Calendar view. I run Zwift at same time as TR and the rides to show up in Zwift and Strava accounts. Sent email to Support Team to hopefully remedy. Seems the problems started when I switched over to use of the Calendar?