Max Speed from TrainerRoad on Garmin Connect

What’s the fastest you’ve been on your turbo? My mate was faster yesterday when he completed Polar Bear. I guess his Elite is faster than my Tacx.

3 Likes

And this is why people have asked repeatedly for the indoor distance bug to be fixed.

Friend: I did 60k today.
Me: Nice, where did you go?
Friend: Oh it was indoors.
Me :neutral_face:

2 Likes

It’s often down to using ERG mode and gearing at one end or the other.

  • Higher gearing leads to faster “speed” and longer “distance”.
  • Lower gearing = the inverse of above.
1 Like

I use the inner ring as it’s quieter.

Never had a speed ramp like that before, always previously had an approximation.

I’m not fussed, the workout was as expected ( although it was a breakthrough :grinning: ) just acknowledging a change.

I got this bug last night, apparently I managed to ride 49,931 km at a top speed of 566,100 km/h during my 2 hour tempo workout: Garmin Connect

I sent the faulty FIT file to support, they acknowledged they’ve received multiple reports of this and they’re looking into it.

3 Likes

It’s like a TR Top Trumps. If all the TR Team had a card that had their weight, FTP, Max Speed, Fastest 10 mile TT, power to weight, power to CDA, most beer drunk, who’d win each round?

that’s a proper ramp test!

1 Like

Same problem for me: TR Fit files exhibit ridiculously high speeds

Worked last week, gets it completely wrong since this week (yesterday and today).
Must be related to last update:-o

But we are talking about 4 orders of magnitude off…

Copy that. I didn’t see that scope initially, so it’s worth pursuing in whatever method is appropriate. I have no idea where the new problem came from, so could be worth contacting multiple support services as appropriate.

Update from the team:
This was a known bug, that the fix has been released for! Yay!

To fix any rides that are affected, athletes need to delete the ride on Strava/Garmin Connect, download the TrainerRoad workout, and manually re-upload into Strava or Garmin Connect to show accurate speed data.

2 Likes

Worth noting that deleting and reuploading manually to Strava means it won’t have the TrainerRoad graphic with the progression levels and intervals, in case that matters to anyone.

Funny, I thought that I was the only one that had that issue on a ride two days ago. Here’s a screenshot of the speed from that ride:

The ride was weird for me since average speed looked about right and distance made sense, but the random linear increase to speed while cadence was stable didn’t make much sense. Just a random glitch where speed appeared to be a cumulative build over time. Either way, good to know the problem is solved.

1 Like