Kickr core resistance seems too high?

Hi everybody I jumped on my kickr core tonight to do a workout and for some reason it seemed incredibly difficult. Even at 78W in a workout it felt much more difficult than normal. I did a ramp test yesterday and saw my ftp increase by 4 after 8 weeks of training which to be honest I was slightly disappointed by as I know I’ve definitely gotten stronger.

Jump to today, back in the saddle for a workout. Even at 140w it feels like I’m in the 200’s.

I stopped the workout and did a spindown and it still seems the same.

I understand it could be still soreness from the ramp test but the difficulty in resistance honestly seems way too much for that. Has anybody here had issues with the kickr core giving out much lower watt readings and therefore making it difficult?


Advanced spin down if that still exists in the wahoo app.

1 Like

That’s what I did before I got back on it again today.
Has anybody else had this issue?

I had this happen once. I had to reset the power to the unit and it was fine after that. I’m assuming you have tried this already?

I have. Did the power off and on fix yours? I’m guessing your power difference was significant also?

It was enough where I thought “this isn’t right”. However after resetting it, I haven’t had an issue in over a year now. I’d be curious what wahoo says.

I’ve had that happen a few times and while I’ve never conclusively figured out whats going on my hunch is the Kickr is paired with the wrong app. It doesn’t happen often but it seems more likely if the Wahoo app is open or my Garmin is on. My fix is to close all apps on my phone (my preferred device) then unplug the Kickr for a bit (15 seconds or so) then plug it back in. That has fixed it every time.

What gearing are you using on the Core? Is it possible you are used to a much higher inertia trainer and now you are using a low gear and the increased inertia is harder?

Just double checking that you did the advanced spindown, not just the regular spindown.

Also, for what it’s worth. I did the Ramp Test yesterday and today I did Petit and it felt WAY harder than it should. Most likely it’s just your legs if nothing else in your setup has changed.

This is the only trainer I have used and have had it for ~8 weeks or so. It only really happened yesterday.
I reset the kickr, reset all bluetooth devices and even tried an advanced spindown, but when I do the spindown the speed on my app just shows as n/a even though it shows that the kickr is connected.

Hi Julian, I tried both the normal and the advanced spindown…When I do either, on the screen that it asks me to pedal to 36 KMH, the speed just shows as “n/a” or “-” even though I see that the device is connected.

I even tried to start a workout and enter the spindowm that way - Same issue as above…What is strange is that in a workout I am putting out almost 600 watts to get anywhere near 36 KPH - This alone is what is making me think there is something wrong.

1 Like

Ahh I didn’t catch that this happened after riding it for a little and not right out of the box when you set it up. Have you contacted Wahoo Support? They may have a more advanced reset or firmware reboot available to try to set it right again.

Going to call them this morning once I get a gap with work calls. Firmware shows it is up to date.

Ya, that’s not normal behavior. Are you using the Kickr as a the power/cadence source, or do you have a power meter?

Kickr as the power source - I have the Wahoo Cadence meter

I am now on my my third Kickr. Wahoo have replaced two. Each one has had this power problem. I have to say the spin down is a complete and utter red herring. makes no difference at all. The only thing that seems to fix it is to uninstall Zwift completely and reload. Wahoo fail to acknowledge the problem as being real and Zwift blame Wahoo. I am only here because I am looking for answers as the third one is now doing it. I think another app pairing with it might be a clue. Another for me is my wife and I both use the same unit. I have had about a 4 month lay off, as soon as I started to use Zwift/wahoo the problem first crept back with me and now with my wife. Any suggestions? Someone mentions a reset but what does that mean, anything other than unplugging. I really wish there was a reset to factory settings but that definately does not exist.

1 Like

I’ve just had my Kickr Core collected and a replacement sent out because of similar issue, after the latest Zwift update Jan 21st 2021 I’ve gone from 3.8 W/Kg to 2.8 W/kg, I just can’t hold the same power for any period of time. I’m now thinking maybe my Kickr power output was wrong from the beginning and now its correct after the update ? I did a ride on Zwift yesterday using a Tacx Neo 2 turbo connected via Ant + and had my Wahoo head unit via bluetooth both gave a similar power output, and the perceived exertion was similar to the Kickr after the update which leads me to believe it was wrong and somehow righted itself after the Zwift update. Now I could be waaaay of the mark here and would be delighted to be corrected and have my upper power and ftp restored, so if anybody has any ideas as to why I’d be delighted to hear them,

Same here. On the road, I hit 36 KMPH with not much difficulty. However, on the Kickr Core, try as much as I can, I don’t seem to be able to cross 30 KMPH.