Bike Build - Brand New Ultegra Rear Derailluer 8050 Di2 11 speed - Troubleshooting help

Hey Everyone,

I recently purchased a brand new 8050 Di2 Rear Derailleur for a bike build I am doing. I have connected all e tubes and connected the bike to the computer via E tube projects.

The Rear Derailleur appears on the software and is able to update the firmware. Then when I go to test out the shifting. Only the Front Derailleur responds to the controls. Rear Derailleur nothing.

So I plug in an old RD 8050 Di2 sitting on my other bike, works on the new build. I plug in the New RD into the old bike setup, also does not work.

Its weird that the software is able to read the brand new RD, but none of the bikes seem to want work with it. Does anyone have an explanation or guidance on how to fix this?

1 Like

Perhaps the rear derailleur is in “crash mode”? Easy to reset if so, via a 5+ second button hold on the junction box until it flashes red, then you’ll need to spin the cranks to cycle the rear derailleur through the gears.

Weird timing because this exact situation is happening to me, it’s a brand new rear 8050. Testing with another rear derailleur and the setup works but it won’t shift on this particular derailleur. I was also able to update the firmware too. Did we both get duds?

I just tried to do the crash mode reset, it worked on my old RD, but doing it on my new RD…nothing.

Going to have to face a lost here. Contacted the seller and no response yet sadly, been about 5 days.

@Tyler_Waldron - I think we can now be called the dud brothers haha.

I had another di2 12speed RD recently go bad on me recently, I created a warranty request directly through Shimano and they sent me another. I did have to provide proof of purchase but other than a slightly slow process, it was easy. So that’s an option maybe. I bought mine through eBay so I should have purchase protection.

I just have to think there’s something else going on. I was able to put mine in the adjustment mode and it moved once. I might try to rewrite the firmware in the software and see if that helps. Could it be an incompatibility with another component? I vaguely remember something about the newer 11 speed battery and it not playing nicely with everything.