Error publishing workout

Hi guys,

I’m struggling with a problem of publishing my custom workout via Windows app. My Adobe Air is updated, the app is updated too. I use Windows 8.1.

During publishing process, in the creator, in left bottom corner, the text “Error publishing workout” shows.

Any idea what can I do with this issue?

If anyone has the same problem. This is what worked for me (from Trainerroad FB profile):

“This happens when there’s a problem communicating with Trainerroad, which is usually solved by logging out and back into the Workout Creator. Also logging into the website could help establish connection.”

1 Like

I’m in the same situation- error publishing workout- logged out, tried again. Any further advice?

Re-loggin helped me. But you can try this:

The are further advices.

1 Like

Having the same issue…

Were you able to try the troublesooting steps outlined above?

To summarize:

  1. Log out of both the WC and the TrainerRoad App
  2. Log in to WC
  3. Publish the workout in the WC
  4. Log into TrainerRoad
  5. View Custom Rides tab to see if the ride published

Keep in mind that you will need good WiFi reception during this process.

Let me know if this works :ok_hand:

1 Like

Thanks Mate!!
Did the trick :+1:

1 Like

Thank you! worked. For anyone else having issues - the problem seemed to happen after I had to update my TR password. I think I had remained logged into WC with my old password, and they couldn’t communicate. Manually logging out of WC and TR and following bryce’s order of operations worked

That worked for me too!