New MacBook Air M1 won't recognise ANT+ dongle and HRM - Help please

Hi all,
I have recently bought the new MacBook Air with the M1 chipset 2020 running Big Sur
I have a Elite Drivo connecting with bluetooth along with a Garmin HR strap ANT+ and use an ANT+ dongle to allow the TR app to connect. The dongle connects to the Mac via a cable to go from USB to the new port on the latest MacBooks.

I simply cannot get the ANT+ to be connected using the new MacBook Air… shows as off in the app.
To test whether it was the HRM or Dongle that had the issue I used my work MacBook Pro (2019) and it all works perfectly…

Anyone else had similar experience with the new M1 chipset MacBook Airs? Anyone resolved the issue?
I’m at an absolute loss what to do now

Thanks in advance,

What USB-C to USB adapter are you using?

I have a M1 Mac Mini with native USB ports. My ANT+ dongle works fine there. I forget which one I’m using right now, might be a Garmin.

Bought from Apple I think though I’m not 100% sure if it was TBH, but it works with the Pro… we have an old MacBook Air too with normal USB and the dongle just goes in without an adaptor and this also works fine

Which is a different implementation.

On x86 the USB is on the SouthBridge (Intel). With M1, that’s all different now. So, it could be some sort of compatibility issue. Since it works on my Mac Mini, it could be an issue with compatibility with the cable.

I can try out an Apple USB-C to USB dongle later today on the Mac Mini.


@bryand it works with the USB-C to USB adapter I have from Apple. I also use a 6ft USB-A extension between the adapter and the ANT+ dongle.

Try rebooting, if it doesn’t work, try contacting TR support. It’s hard to say what the problem might be.

1 Like

Thanks for taking the time to check. I’ll try a reboot see if that works. I’ve also ordered a new cable from Apple too, to see if something odd is happening in regards to the cable that I have currently

So, new cable arrived from Apple, no change. However really interestingly when I test the setup with RGT the HRM is picked up which suggests there is something going on with Trainer Road specifically and the new MacBook… or perhaps my settings in TR on this laptop however I’ve not knowingly changed anything… the fact it works with RGT has really confused me now :frowning:
I’ve emailed the support team. Hopefully they may help with some tip to resolve


So, we have a resolution! Thanks to Bryce at TR support… seems the Mac version isn’t on the App Store yet and it defaults to the IOS version which via the Mac doesn’t;t allow ANT+ to work… so an uninstall and reinstall using link directly from TR website and it now works perfectly

So in case anyone else has a similar issue here is the email that resolved my issue. thanks to everyone for all your help

Bryce L. (Trainer Road)

Hey Bryan,

Thanks for reaching out about this and congrats on your new computer! I’m so sorry things aren’t working smoothly out of the gate, but I’m sure we can get to the bottom of this.

As I’m sure you know, the M1 Macbooks run an ARM processor, unlike the x86 processors that Intel uses. This allows it to install both macOS and iOS (mobile) versions of the application.

While it is technically possible to install the iOS version of the app from the App Store, it will not allow you to pair via ANT+, so I suspect that this is your issue here. We have not yet added the macOS version to the App Store, so when you search for “TrainerRoad” it automatically serves you the mobile/ iPad version of the app without giving you much warning.

Go ahead and download the macOS version of your app using the link below, and let me know if that resolves your problem :+1:



That’s interesting! Curious why the M1 Mac mini serves up the proper version. It’s the x86 version but it’s for the mac.

Maybe because I downloaded from TR?

Yeah that’ll be it the proper version for Mac OS is available on the TR website directly but not yet via the App Store

1 Like

You should be able to connect via bluetooth on macbook

my Garmin HRM only works with ANT+