Early Access to Android Beta - Updated TrainerRoad

Thanks for the suggestions and feedback everyone. We have been spending the majority of our time recently trying to track down some the crashes we have been seeing during backgrounding or navigating back and forth to TR from various apps. We have some logging in place, and some improvements. If you have been plagued by this at all in the past, please give the newest build a try and we’re going to be releasing another version in the next day or two with more logging and more improvements. Use TR exactly like you would in your normal training, the more strain the better :smiling_imp:

Here’s a quick rundown of what was in this latest release.

•	Fixed a problem with Workout Name & End Time shrinking with switching between landscape and portrait modes. 
•	Fixed a problem where an account name could get into a bad state under Account
•	Fixed a problem where ending time could be clipped on some devices
•	Fixed a problem where sometimes it would be impossible to log back in after a crash
•	Added the Outside TR Icon to the Workout Cards
•	First round of VocieOver improvements were implemented
•	Fixed a problem where Training Plans could show 0 for Hours and TSS
•	Added logging for various problems and crashes we were seeing mainly on older devices

Sorry, but what is that, or VoiceOver? :nerd_face:

Anyway, i am more then happy on Samsung Galaxy S4 Tablet, very stable now for me, seems more and more german translations in workouts are coming too! :+1: :+1: :+1:

1 Like

I feel personally attacked. :rofl:


@Pete Thanks for the changelog!

for the record, I have been using the beta almost since the beginning on a samsun S10, and for me there are less and less issues. In the beginning there where frequent crashes etc. but now I have been using it normally for a while. Just a freeze in the calendar once in a while or a hanging or crashing sync, but in most cases it just works normally :slight_smile:

I/m pretty happy with it right now, ANT+ working fine (for my old HR strap), combination of BT and ANT+ is also working fine (where I got dropouts requiring an app restart on the production build on my S10 with the ANT+ and BT combination

1 Like

Hi Geoff,
Today I did Dans having replaced my Powertap hub batteries.
Below are 2 pictures as you can see the Wahoo is reading speed and distance and TR isn’t (there used to be a field with mph showing in the old app if memory serves me right). Powertap only puts out Ant+ not Bluetooth.

On the good side the 3 digit end time is now fixed for me.
Syncing on completion of the ride was much faster and no crashes.

Is this still a closed beta, or can you request access?

Thank you for the additional information. I’ll make sure that we look into this one on our end, we definitely want to be capturing speed readings from any device that reports them. :slight_smile: So for now, know that it is not intentional that you aren’t getting mileage in Strava and hopefully we’ll have an update for you in the near future.

You can request access here:

@Pete will then have to accept the request.

1 Like

After calibrating my trainer after the warm up today I returned to the workout but the “pedal to play” didn’t work. Worked at the start of the workout and after stopping in one of the rest intervals (to check if the function was not working mid ride at all). Screenshot shows that I’m pedalling and everything is being read, just not restarting

When I stopped mid ride I also noticed that it took a number of seconds to stop the workout. It was reading that I was pedaling at least 4 seconds after I stopped and didn’t pause until the power reading was down at 0 (after about 10 seconds). No screenshot of that as I couldn’t work out how to video it.

Samsung A40
CycleOps M2
Garmin Vector 2S

1 Like

It seems there’s couple of workouts that showing blank on the updated app

Well, at least it’s fine on the inside

1 Like

I’ve hot lots of them showing blank…

1 Like

I was trying out fulgaz yesterday and 3 short setup rides uploaded to strava from fulgaz. I deleted them from strava and deleted them from my calendar in the app. However they still show in my browser calendar and I’ve tried deleting them 3 times from the browser calendar but they keep coming back :thinking:

1 Like

Just having a search through the list of workouts and i can see loads of workouts missing their image…

1 Like

I was doing a search for Birch today (to see if what a friend on Strava had been doing would be an easy option for today) and this came up… ie partly missing graphic.

It was all OK 'inside it" though.

However, it is also a partial graphic when scheduled in Calendar

Something seems to have happened. All I’m seeing now is a black screen. I’ve tried clearing the app cache to no effect.

The beta app is unusable for me now :frowning:

1 Like

Completed Free Ride 30 as a warm up.
App crashed completely on completion.
Samsung S7

However it did sync to Calendar whilst crashing.

on saturday i started a ride, after arround 20min, the info of 3 paired devices changed the color from green to orange, at first I was a little confused, then i looked inside my paired devices and seen that my Vector 3 have low battery, total fun, 1 minute later my Edge 830 reported me the same! :nerd_face: :ok_hand:

Interesting, the V3 battery i replaced the last time in July 2020, so a half year later this message is awaited!

1 Like

I have also been having the problem that after doing a spindown calibration on the trainer, the workout stays paused at the “pedal to resume” screen, but does not resume until I manually press the resume button.

My last two rides my Garmin Heart Rate Meter has said it was connected, but no HR was displayed, just two dashes as if it weren’t connected. Tried forgetting the device and reconnecting but that didn’t help

I’ve been getting this on the standard (non beta) release for ages. Thought @Pete and @Nate_Pearson might want to see although it’s probably already been spotted

1 Like

Uh oh! Black screen of death has made a reappearance on the phone. Did a ramp test and the app worked perfectly earlier this evening. Logged on to check what run I had planned tomorrow and when I came out of the workout the whole thing crashed. Closing and reopening flashes up the workout list but then all disappears and I’m left with a black screen.

1 Like