Early Access to Android Beta - Updated TrainerRoad

The cadence line is not showing in my workout today. I thought that it will magically pop out in the middle of workout but it isn’t

You have to enable it under the settings ootion


1 Like

Ah I see… thanks

It’s automatically there from the first I used TR beta. Didn’t know that it turned off

1 Like

They changed it


I’ve done a couple of workouts now, using a galaxy tab S7 and it’s been very nice! Some minor oddities with landscape/portrait but that’s about it. I also noticed that the power adjustment on my neo takes place at 0s where the iPad app (not beta) would adjust the power 2s ahead of time. So that’s very good :slight_smile:

1 Like

I have now been using the Beta on my S10+ for a couple weeks. My thoughts are:
It crashes a lot while I am scrolling through the calender but has not crashed at any other time.

Occasionally when I switch to another app during a workout, when I come back to the TR app it will show no connection to the sensors and the workout graph will show a second or two long break. However after the ride is complete these interruptions don’t show up.

When you complete a ride the TSS shown will be way off, once the ride syncs it then shows the correct TSS.

Ride sync was slow but lately had been quick.

In the training plans section, some of the plans show 0 for weekly hours and TSS.

Often when I open the app it takes 5-10 seconds to load, just showing a spinning red circle.

During the workouts everything is working well.

One other thing I noticed was the weekly tips have the same white text as the rest of the calender. I think that it would help if this text was a more noticeable color as until recently I didn’t even realize there was weekly notes on the training plans.

1 Like

This happened after cleared my baird -2 this evening.
I’ve planned 2 workout today, baird -2 and lazy mountain -2. After cleared baird -2 I don’t wanna do the lazy mountain and delete it. Unfortunately, the lazy mountain -2 can’t be deleted so I try again to delete it until the app crash. After that I try to open the app but it just show me this blank screen again and again. I restarted my phone, but nothing happened.

Using TR beta since Desember on my redmi note 8 pro. No major complain until this happen.

Still shows loading screen after opening the app

And after that this blank screen

I decided to reinstall the app. It’s working again but all my favorite workout is gone

1 Like

I use a Cycleops Magnus trainer. I normally calibrate using the Saris app. I noticed I can now calibrate in the TR app. So I’ve tried it a few times and have really variable results. It seems like it is setting very different levels of resistance on different attempts. Normally pedaling up to the required 24mph requires about 200w then holding around 150w for 20 seconds until coasting. Sometimes the resistance is so high it makes me go over 400w to hit 24mph.

This is on a google pixel 2 with android 11. App version 2020.36.0.92034


This morning, after completing my ramp test (woohoo!) I tried to open the TrainerRoad app, but I consistently get a blank, unresponsive screen. I can still close the app and continue using my phone. The screen shows the normal red loading-spinner, and then flickers what may be the calendar view, but goes blank.

Samsung Galaxy S10e, android 10, app v 2020.36.0.92034

Uninstall and reinstall worked to fix the issue.

Since updating the beta app just now wit the latest version, the syncing message at the top top with the red spinner is continuously on and remains on.

Same, s10e. App hasn’t worked since my ramp test yesterday. I guess I’ll have to try a reinstall?

On Samsung Galaxy Tablet S4 everything looks fine for me now, next week during Recovery week i will try my Mobile Phone (Samsung M31), are there any Users here who have experience with Samsung M31 or know issues have to be checked?

@Pete is there a changelog for the new version?

When adding a plan to your calendar you cannot move any of the training days when shown the 7 day block. e.g. you cant move the Saturday workout to the sunday. If this isn’t going to be a feature then the option to add a plan via the app shouldn’t be available.

1 Like

Had to close & reopen updated app 3 times to get a connection to Powertap hub ant+.

Finish time showing only 3 digits again.

Shouldn’t completed time be the time you finish not start time

It is 17:21 or 5:21pm here.

No milage pushed to Strava… this is extremely annoying considering previous non beta version does this.

First, thanks for trying out the beta and giving us some feedback! :slight_smile:

Finish time showing only 3 digits again.

We think that we’ve fixed this in the latest release which went out yesterday. It looks like your ride was on the previous version, so hopefully you’re prompted for an update and this is then resolved - let us know!

Shouldn’t completed time be the time you finish not start time

We show start time here across our ecosystem - I just verified this on web, desktop, and our current (non-beta) mobile app. I think there’s a discussion to be had here though and I’ll make sure to pass your feedback along.

No milage pushed to Strava… this is extremely annoying considering previous non beta version does this.

I took a look through your logs, and we didn’t get any speed data from you; without it, we can’t report mileage. Does your speed data normally come from your PowerTab hub or do you have another device that reports it which may have not been paired?

I see that “The PowerTap hub measures the speed of the hub by using a speed sensor within the hub and a magnet attached to the axle.” - would you mind double checking that everything is set up correctly in this regard? I’m hoping that there’s a simple setup fix here. :slight_smile:


I just double checked that you can do this, but the drag and scroll behavior does seem like it could be more responsive on some devices. I’ll see if we can look into that.

In order to drag the training day, make sure to “hold” your finger on the card for a second or two in order to “unlock” it. You should then see it become movable.

Thanks for the comments Geoff.
My Powertap has never had or needed a magnet since I have had it to give speed data to my Wahoo Element Bolt or Garmin 800 or Garmin 910 or Garmin 500 or the none beta version of the TR app.
It still quite happily pushed out the info to the Bolt & 800… as it was on my non TR log of 4th Jan but not those TR logs near it.
I’ll try changing the batteries & see if that helps.

1 Like

Still happening after update. Moto X4, Android 9, TR 2020.36.0.92035


Just a feature/workflow modification idea. I didn’t have a workout scheduled. Usually the Calendar is up on my tablet, and it’s scrolled to an empty today. It offers to “find a workout”, which I did, but was a little annoyed I couldn’t just start it right away, I had to schedule it first, wait for syncing, then bring the workout up again before I could load it. I think the schedule button on the calendar for “today” should at least offer to start it right away. Ie, it should behave more like when you go to workouts tab to find a workout.

Also, I like how the workout search auto-updates as you type text, however as I was looking up “pettit” I noticed once I got to “pett” it was down to 3 results, and as I continued to type the “i” and “t” the search results would flicker, but redraw the same. Its (visually) distracting, and slow, to redraw the results if they haven’t actually changed. Just an idea to eliminate the redraw of results if they haven’t changed.