Using TR and Zwift Concurrently

Except Wahoo trainers, they power/speed but not cadence. Wahoo provided a separate cadence sensor with my Kickr 2017.

1 Like

Slightly off topic question, but figured I could ask this here instead of creating a new thread. I have been attempting to use Trainerroad through ANT+ on my laptop with ANT+ stick, using a Hammer trainer, while pairing Zwift with bluetooth through Apple TV. But I’m having trouble finding a reliable way to do this without the programs fighting each other for control. Is it pertinent to start one application before the other?

Trainerroad is set to ERG mode and works flawlessly on its own. When attempting to pair with zwift through bluetooth it seems like trainerroad relinquishes control even if not selecting controllable trainer on zwift. Other times it seems like they both cancel each other out and puts it into a freeride mode. I’ve tried starting one program before the other and vice versa, but just cant quite figure it out.

I’ve just been turning zwift off and going back to youtube videos and doing my workouts on trainerroad, but would like to add zwift just from the entertainment standpoint. Anyone know what I’m doing wrong?

1 Like

I’m using the Hammer trainer for my Zwift/TR rides. This is how I approach it, and things have been working for me.

I open Zwift first. I have Zwift connect to the trainer via ANT+ for speed and cadence. I then open up TR and verify the Hammer connects via Bluetooth. I start the workout, expand the workout to full screen so I can then select the minimal window option. I drag the TR back to my desktop — I’m working on a Mac laptop — move TR to the bottom of my screen and reposition and resize Zwift appropriately.

I’ve done this for five or six workouts and can see that the power display is the same in both programs and that the wattage adjust according to the target in TR.

Hope this helps.

Make absolutely certain that you deselect the Hammer from the “Controllable Trainer” box in Zwift.

It MUST NOT be paired in the “CT” box, or TR & Z will fight to control the Hammer.

You can have it paired in the “Power Meter” box.

2 Likes

I’ve done this in the past using a Windows PC and ANT+ stick. I used ANT+ and TrainerRoad and then ran Zwift on the PC and used the Bluetooth from my Android phone and the companion app. This is pairing to my Cyclops Magnus.

Previously that worked fine. I tried to do it again this weekend and was unable to get it to work. It seemed to me that no matter which order I opened the apps, Zwift would always go grab control of the trainer via BT. Even after I then deselected it my Magnus was stuck in Bluetooth control mode and required a power cycle.

I eventually ran out of time to do both my workout and IT support so gave up and just Trainer Roaded it and watched videos. It seems like something may have changed on one end or the other (TR/Zwift). I’ll want to try it again when I have more time to troubleshoot.

I got this to work for my last workout, and here’s what I did. Opened zwift and paired everything, making sure “Controllable Trainer” was unclicked. Opened trainer road and made sure everything was paired, and started workout. At this point trainer road erg mode was not in control as I started riding. I closed zwift and continued riding on trainer road, and within 15 seconds or so, trainer road erg mode took control and kicked in. I then re opened zwift and quickly clicked past the pairing screen, as to not allow it to auto select “controllable trainer”. Everything worked from here on out in the workout.

For reference, I am using ANT+ stick on laptop running trainer road pairing to hammer trainer, and Apple TV running bluetooth for zwift, pairing to hammer trainer.

1 Like

Hi,

I do this all the time as I find that the “Eye Candy” effect of Zwift helps the intervals.

I always start TR first and pair it. Then open Zwift and, as others have said make sure there is nothing paired in the controllable trainer box. Since TR is driving there never is in my case but I still check it.

It works every time.

Thanks

1 Like

To those who discard the ride in Zwift - does that keep the XP points achieved during the session? I am guessing so as they are allocated as you add an extra mile/km

I don’t think the xp points are saved if ride is discarded. If you’re not looking for the Zwift ride to show up on strava etc. just make sure Zwift isn’t synced to any other sites and saving the ride will upload to your Zwift history. Some people like to keep their Zwift ride on strava for the slight elevation bump.

My xp and challenge progress is saved even if I discard the ride (PC). However, if you force close zwift without ending the ride you might lose some or all xp/miles/elevation. Next ride take a look at your xp # before you end the ride, then discard and start zwift again to confirm if its the same.

2 Likes

Its been a while but doesn’t Zwift still let you select/deselect what 3rd party services you want to share your ride with on the save screen? Back when I was using both TR and Z, I would let TR sync with Strava and Garmin and then deselect those services on the Z save screen so I still get the ride logged in Z for reference.

Hello - this old chestnut again.

While this used to work for me, I don’t seem to be able to do this anymore. Whichever app I launch first seems to hog the ANT connection…

Additionally, in TrainerRoad, my Kickr shows up as one device with both ANT and BT symbols. Is there a way to split it? I could connect my Flux in such a manner…

I do this, but I have power meter pedals which I hook up to Zwift and then my trainer is an Elite Suito which I hook up to TR for erg mode.

I hook it up to Zwift mainly for the drops and levelling up.

Can you list your exact devices and available connection (BLE and ANT+) for Zwift and TR?

Sure:

  • Macbook Pro (Catalina) with ANT+ dongle
  • Kickr
  • Favero Assioma (ANT)
  • Garmin HR (ANT)

I don’t bother using the BlueTooth connections for any device.

I would typically have both applications reading power from the PM. In Zwift, I’d tell it to ignore any ‘Controllable’ source; TR would use PowerMatch on the Kickr,

Both applications should be happy reading the ANT streams from all devices, per my previous experiences, but apparently not.

From my experience, I have had to use one ANT+ dongle per app, on my PC. I don’t know how the Mac works, so it could be different.

The update to the TR desktop app seems to be giving more problems like this than the older version.

You might try reversing the app launch and pairing order (if you haven’t already) to see if that makes a difference.

1 Like

I’m currently having the best luck with launching Z first, then pairing TR. I only occasionally have issues getting my HRM to pair with TR after it’s paired to Z. I use both ANT dongle and BT.

1 Like

Sorry: I drafted this, but never hit reply. Additional information below!

I’ll give it a shot.

My back-up plan is that I’ll run Zwift on the phone and use the BT connections – I’m less fussed about HR

I did this… but I really don’t know what’s happening. The devices are being lumped together.

When I turned Bluetooth off – so that the phone would be the one to connect with that protocol – the only device recognised was the power meter (ANT). Not even the ANT signal from the Kickr…

(Note, my Garmin HR died due to watersweat ingress…, so now running the Tickr)

I agree with Chad, I think you need two Ant+ dongles in order to run both apps together.

I’ve been using Zwift with TR since the weekend. Chrome casting is ok in watopia but getting break up in London/ New York etc.

Given this could be an extended period, I’m considering going the Apple TV route. I assume 32gb is enough for zwift (and maybe netflix/ Prime)?

I’m still planning on sticking with TrainerRoad for training, but zwift will replace the outdoor group spin - quite enjoyed Innsbrook last sunday, have my first group ride lined up for Sunday morning. At the moment, I’m listening to news (need to for my job) rather than my traditional netflix/ eurosport entertainment options .

1 Like