Help Required - abismal ERG mode

Sorry for the repeat post but thought I might get a little extra visibility with a new thread…

Had an absolute nightmare with powermatch ERG mode yesterday.

Setup is Assioma DUO with Tacx Vortex smart trainer over ANT+ to Win10 PC

It’s like its not even trying! What hurts the most is it not slackening off the resistance after the intervals.

Power readings measured from both devices not too far off when viewed in the “devices” screen but did notice that the power from the assiomas lag behind the vortex by around 4 seconds.

Any advice on a way to improve things? If i turn powernatch off can I still have power recorded from the pedals with the vortex adjusting resistance? I’d rather it be stable at a slightly incorrect setpoint than what happened above.

Also do you think it would be any better using bluetooth instead of ant? For the last too intervals I switched to my phone and connected via bluetooth and it seemed a bit better - i was able to maintain a roughly consistent cadence but then the signal to my pedals dropped out because my phones bluetooth antenna is so poor…

Awesome that you can switch device and resume a workout by the way - totally didn’t expect to be able to do that!!!

Here’s a bunch of links to threads that you may find helpful; there’s a bunch more if you search for ‘ERG’ in the search feature

If you’ve got a power meter just ditch ERG mode in my opinion. You don’t need it, you’ll learn to judge things a lot better by self regulating. (RANT OVER).

Easiest solution is above. Drop one from the equation and roll with it. You could use pm and non-erg or just your trainer for pm and continue to use erg.

Actually trying the latter alone could rule out the trainer as the issue.

Second thing to chase down is firmware on both items. I have a tacx vortex and it didn’t work right until I updated firmware.

Third - dig through those threads and start checking off the tips one by one.

When I have power match enabled I can’t stand Erg mode. When I disable power match I love Erg mode. Except I wanted so bad to use my power meter for indoors and outdoors for consistency. I asked TR to look at my files and they saw some interference, so I did a test with all other electronics turned off and nothing changed. Then it was brought up that having a single sided meter makes power match even more tricky. So in the end after a bunch of spin downs on my Kickr Core to get the Kickr to read very close to my PM I’m trying Erg mode enabled and power match disabled. I monitor my intervals on my Garmin reading my PM and if they are a little off I just adjust intensity to get as close as possible. I did notice the warmer my trainer gets it’s within a few watts now. I did slightly manipulate my spin down just a touch until I was happy. Probably not recommended…

Cheers :+1:

Good idea regarding trying just the trainer and seeing if it’s any better - love a good experiment.

I’m not really keen on ditching ERG mode, I like it and it worked ok on that other program that I’ve just cancelled my zubscription for…

I’m wondering weather I just had a really flaky ant+ connection to my trainer. I’ll go trainer only and see if it’s any better - I can always record my assioma power using my head unit to see if it’s much different to the numbers the vortex spits out.

One of the thing with ERG mode on vortex is you have to change gears. To high and a reasonnable Cadence will push you over the watts you are looking for. You have the same problem with too low a gear you might not be able to do the required watts.

1 Like