Bug Reports for the new Desktop App

Oh okay … that’s a bummer … is the link for the latest download just the same link I used last time? I can’t see a way to update it from inside the app. I haven’t received any notification that it wasn’t the latest either.

Thanks, had to do a restart as it would allow deletion of one of those but seems to have installed OK now.

1 Like

+1… the same thing happens and I seem to be chasing up cadence during warm up. Is this issue being looked through?

The update should download automatically in the background while the app is open. Once it’s complete, a green banner will show up across the top of the app and indicate that you should restart the app to apply the update. There’ve been a few reports of the update process taking a long time, and we’re looking into it.

Check this forum out for the most recent update version. As a note, the Mac version is 2019.25.4.44 right now. Typically, that last number changes sequentially, so the the next update will be 45, then 46, etc.

1 Like

According to the ride logs, those rides were done on the current WPF production app. Could you make sure you’re on the most recent Beta? The version number for Windows is 2019.25.4.48, and you can see that in the Support tab of the app.

You can download the Beta from here: www.trainerroad.com/download/beta

New beta updates should be out now!

Windows: 2019.26.0.49
Mac: 2019.26.0.45

Release notes:

  • Outside Workouts are now live! You can now schedule outside workouts within the app, even if you weren’t a beta user for that feature.
  • Fixed an issue with the ‘Today’ button not working properly

If you’re unfamiliar with the Outside Workouts feature, there are more details in these threads:

This is pretty exciting for us - we hope you enjoy!

Thanks and, as always, let us know if you run into any issues. :slight_smile:


Thanks I gave it a shot this morning - I just re-downloaded the app before I saw this message!

But it worked fine today - devices connected fine, other than the heart rate dropping out (or unusually low really) about 2/3 of way through workout. Any ideas whether that’s a Beta issue or just my TICKR?

FYI I just bought a brand new one to rule that out as the problem. Connected totally fine straight away to Beta. But the incorrect reading is concerning (went from around 170 BPM to 130 BPM in my fourth and hardest interval! You could see my workout from this morning if you’re interested.

Thanks for getting back to me. I’m glad that everything, for the most part, worked out today. I took a look at the ride itself, and that definitely looks like something went wrong. That said, digging into the logs didn’t show anything wrong as far as connectivity goes.

It’s possible that the new TICKR might’ve shipped with a half-dead battery or something. I doubt that actual hardware of it is defunct, but try changing the battery if you haven’t already.

Also, try out this little trick to see if it helps. Press ‘option + shift’ while clicking on the Bluetooth logo in your menu bar. An option to debug > reset Bluetooth module should show up. Reset the module and let me know how your next ride goes.

Also been having issues connecting Wahoo Ticker via bluetooth - not even an option the last few rides so connected via ANT+, bluetooth connected this time to Ticker. Workout power/cadence froze about 52mins into workout then Ticker dropped out about 56mins, stopped and connected via ANT+ and worked for the rest of the ride.
Hope the feedback helps.

Platform: Windows
Version: 2019.25.4.48-Beta
Devices: Tacx Neo 2
Connection: Bluetooth
Mode: ERG

1 Like

Just a quick issue and not sure it’s related to the desktop version (beta) however when my last workout did the strava sync, the TR pic isn’t visible, and this has not occured previously?

Platform: Windows 10
Version: 2019.26.0.49-Beta (latest)
Devices: Elite Drivo 2, Garmin HRM
Connection: ANT+
Mode: ERG

Couple of things noticed this morning:

Windows 10.

  1. Was trying to pick some workouts out of Off-road Speciality but there was no scroll bar and the mouse wheel nor arrow keys did anything and all I could see was the Short Track plan, couldnt scroll down to see any other plans.

  2. I’ve noticed a few times, where I’ve gone off piste from a workout, like added some sprints, stomps etc to low intensity endurance rides; when the ride finishes it gives you the intensity and TSS vs. the prescribed figures. At least twice this has been way higher than actual recorded. For example, I did Petit+1 this morning, added a handful of high power sprints and when I finished it gave me 66TSS and 0.81IF, looking at the ride now though it says 57TSS and 0.76IF.

I haven’t had any problems lately (other than my heart rate monitor being dead), but … I’ve been shutting off Bluetooth before rides. I’m going to try leaving it on for the next ride and see what happens.

1 Like

Thanks for the report! Did all of your Bluetooth devices drop out or just the heart rate monitor? I’ll use a TICKR connected via Bluetooth on Windows tonight and see if I have any luck. Typically, as it goes, I never have luck reproducing issues!

I’ve not heard of this happening as a result of the beta app, but I’ve seen it when the partner integrations on Strava are disabled. Make sure they’re enabled here: https://www.strava.com/settings/partner_integrations

Did the picture end up coming through to Strava? Try re-syncing with Strava by going to the ride on the TR website, scrolling down to the bottom of the page, and clicking the Strava icon.

I’m unable to reproduce this but it could be a screen resolution thing or something. Was the window maximized or anything? If you could do a little more digging that would be helpful! Thanks!

Hmm, I had reported a similar issue and we had fixed it before. You’re on the most up-to-date version of the app, correct? Should be 2019.26.1.50 on Windows now.

The calculation in the workout and the post-ride summary are actually not shared code so there could be discrepancy there. I sometimes see +/-1, not anything more than that, though. :thinking:

New betas should be out now.

Windows: 2019.26.1.50
Mac: 2019.26.1.46

  • Fixed a crash when undoing an interval extension
  • Fixed an issue when viewing charts for outside workouts
  • Changed the interval time in workout player to show the first tick of the next interval
  • Minor UI fixes and back-end changes

One of the back-end changes is to help us diagnose/identify the issue that is causing rides to not sync immediately. So the more rides we get, the more logs we have, and the closer we get to fixing it!

Thanks y’all!


@ming first time only trainer @ 52mins, second time only TICKR and couldn’t see it as an option to reconnect via bluetooth, ANT+ was there, connected and worked for the remainder of the ride.

Since the updates the TICKR has had issues with Bluetooth and typically only shows up via ANT+ as an option - really only connected via BT to give TR feedback.

TR on Neo 2 is also smoother via BT than ANT+ - not sure reasoning just some more feedback.




I’ve not heard of this happening as a result of the beta app, but I’ve seen it when the partner integrations on Strava are disabled. Make sure they’re enabled here: https://www.strava.com/settings/partner_integrations

Did the picture end up coming through to Strava? Try re-syncing with Strava by going to the ride on the TR website, scrolling down to the bottom of the page, and clicking the Strava icon.

Hey Ming
I did a re-sync and TR sat there for 15 mins and did nothing (except the sync buttons for both Strava and TP blinked). I went to Ride Sync and disconnected and reconnected and the pic appeared after syncing (which was instantaneous). So looks like it’s fixed itself… so all good, thanks!

1 Like
  • Platform: Windows
  • Version: 2019.26.0.49-Beta
  • Devices: v1 Kickr
  • Connection: ANT+
  • Mode: ERG

I just did a ramp test which reported a very small bump in FTP from 205 I’d manually set it to 208, but that doesn’t appear to have been “saved” anywhere into my account. I’m 99% sure I hit the “Accept new FTP” button…

Version yesterday was 2019.26.0.49-Beta

Yep, you were right :flushed: looked like it was full screen but clicked the full screen button and the slider appeared. Sorry!

Glad that worked! Let me know if it happens again, although I bet that would be more of a web/sync issue rather than anything with the beta app. Thanks for reporting it, though.

We have an open issue about this. Could you clarify what exactly you did? You did the Ramp Test and accepted the new FTP and it didn’t change in your account settings? Or did you deny the new FTP and then go manually change it after the fact?


Still could be an issue - you shouldn’t be able to get into a scenario where things don’t scroll. I’m unable to reproduce this on a Windows machine with different resolution settings, but if you find anything else to get this to happen again, let me know. :slight_smile:

I accepted the new FTP and it didn’t change in my account settings.

1 Like